Problem updating 32GB 4th gen iPod Touch past 4.2.1

Discussion in 'iPod touch' started by timotay89, Oct 19, 2011.

  1. timotay89 macrumors regular

    Jul 20, 2011
    I bought an iPod Touch second hand. It's 32GB, 4th generation (it has a camera, I know what versions this is).

    When I got it it had the picture that the new ones have, the screen used up to iOS 4 saying to connect it to iTunes. So I did. It said it's running 4.2.1 and could be updated. So I tried to update it. And I've been trying for 3 hours since then. Every time I try to update the software, I get a message saying:

    "The iPod "iPod" cannot be restored at this time because the iPod software update server could not be contacted or is temporarily unavailable"

    It ALWAYS happens right after iTunes finishes "Extracting software..."

    I don't have a clue what this means, but it apparently means I can't update the software on the iPod. Can someone please tell me why and and how to fix it?

    I've tried the whole DFU mode and holding down the home and power button thing when starting. I've also deleted the iPod software updates in the ~/library/itunes/ folder, but then it just downloaded the software and again stopped.

    Please help!
  2. herdnerfer macrumors 6502

    Feb 12, 2011
    Saint louis, MO
    Pc issue

    This sounds more like an issue with iTunes or the pc than it does the iPod. I would uninstall & reinstall iTunes and see if that helps. If not I would try upgrading on someone else's computer.
  3. likethesoup2 macrumors 6502a

    Mar 29, 2011
    Orlando, Florida
    I presume you have the latest version of itunes, OS X etc . . .

    Mine did something similar to that on the day iOS 5 was released; I kept trying it and eventually it went through. When it does start, it's a little disconcerting (at least it was for me), as there's really no warning (after you've watched it fail 2 or 3 times).

    So I would just keep trying. I heard (somewhere) that sometimes you'd get an error like that if Apple's servers were overloaded; but I find it hard to believe (at this date) that they'd still be overloaded.
  4. MrXiro, Oct 20, 2011
    Last edited: Oct 20, 2011

    MrXiro macrumors 68040


    Nov 2, 2007
    Los Angeles
    I had this problem running Lion and trying to update my iPod Touch 4 and iPad. I went back to my wife's Snow Leopard macbook and it updated just fine... I don't know why this is or what the deal is.

    I posted about it a few months ago but nobody responded to me about it.

    I was able to update to iOS5 from whatever the last update (4.3.XXX) on Lion with no issues.
  5. timotay89 thread starter macrumors regular

    Jul 20, 2011

    So, I figured it out (well, not me, but someone).

    I had picked it up for my girlfriend and decided to update the iOS for her before she got it. Apparently the iPod knew I was messing with my girlfriend by giving it a weird name to annoy her, so it wouldn't let me update.

    She plugged it into her computer and it was fine.

    Thanks for everyone's help!

Share This Page