problem updating adobe flash...

Discussion in 'OS X El Capitan (10.11)' started by kgflybynyte, Aug 31, 2016.

  1. kgflybynyte macrumors member

    Joined:
    Apr 4, 2014
    #1
    right now when i check adobe flash updates, it shows version of 22.0.0.192

    when i click on "check now" i get the message that states "System Preferences quit unexpectedly while using Flash Player plug-in."

    why is it not allowing me to update or check for updates? could use some help
     
  2. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #2
    Could have been a corrupt install at last update. Two things to try --

    1. Update 'over the top' from the official get adobe site, version 22.0.0.209 is the latest, then check for updates through system preferences to see if it reports you're current rather than the message that you're getting now.

    2. Do a clean install as described at the bottom of the page, heading = "Macintosh", HERE.
     
  3. kgflybynyte thread starter macrumors member

    Joined:
    Apr 4, 2014
    #3
    i tried a clean install and when clicked on the installer i get a message that says "Application initialization error" then that has a yellow-orange banner below that says "Finish"
     
  4. rshrugged, Sep 1, 2016
    Last edited: Sep 1, 2016

    rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #4
    I found another Adobe troubleshooting page for Mac which includes links to Flash Player uninstall tools (step 5), and direct links* to Flash Player downloads (bottom of page under heading "Still having problems?), including for Safari. I've only done it this way in Windows, but it was successful.

    EDIT -- the links aren't to get Adobe, but they are official Adobe downloads. As I recall, they're a more complete install of Flash Player.
     
  5. kgflybynyte thread starter macrumors member

    Joined:
    Apr 4, 2014
    #5
    i tried a number of ways (including advice on this thread) and kept getting "Application initialization error". i gave in and finally set up a chat with apple. they had me try once again all the different ways i had already tried and same thing happened. they finally decided to try to download Adobe Flash Player through the "Safe Boot". for some reason beyond my comprehension, that worked and Flash has now updated.
     
  6. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #6
    Good to know; thanks. Glad you got it sorted.

    When you boot into Safe Mode a lot of startup items are prevented from starting up, like security software for instance. You could have something on your machine that was conflicting with the install. There's other things Safe Mode does as well that might've resolved your issue. It's a good tool to keep in mind. You can read more here -- https://support.apple.com/en-us/HT201262
     

Share This Page