Problem upgrading from 10.13.2 -> 10.13.4

Discussion in 'macOS High Sierra (10.13)' started by davids355, Apr 12, 2018.

  1. davids355 macrumors newbie

    Joined:
    Apr 12, 2018
    #1
    Hi guys,

    I have been trying to upgrade my Macbook pro from 10.13.2 to 10.13.4

    First of all the mac tried to update automatically but it kept failing.

    I read online that sometimes people have had this issue after upgrading to an SSD (Which I had also done recently) so I done a time machine backup and restore onto a standard sata drive, tried the upgrade again and it still failed.

    I have also tried downloading sierra in full form the app store, then running that setup as if it were a new install - someone on another forum said that had worked for them - after I done this, it also fails saying that the drive is too small (Even though its a 500GB drive with only about 150GB used) - and now its stuck in a loop as it reboots and keeps trying to install again and again.

    The other strange thing is this - when I try to clone the Mac OS using acronis, it will not work as it says there is no partition available to clone from, also it says the mac OS recovery partition is missing, so now I am wondering if I have somehow messed up the partitions when I originally moved from the sata drive to the SSD drive (When I done this migration, I fitted in the new blank SSD drive, then I put the mac drive in a caddy attached via USB, then I booted into mac recovery environment and used macs built in disk utility to clone the old drive to the new SSD).

    I am getting really frustrated now, and the current situation is this -

    I have the working SSD drive on 10.13.2. I have a time machine backup so I can easily restore that to a spare sata drive for testing.

    Ultimately I want to upgrade the mac to 10.13.4 and also really want to resolve whatever underlying issue there is.

    I am wondering if there is some way I can do a fresh install so that all the partitions etc are correct, get it updated to the latest version 10.13.4 and then restore back just the applications and data from the time machine backup?

    The complicating factor here is that I am really a windows engineer so although I dont mind working on Macs I am not really an expert and I dont understand them in the same way that I understand windows. So I want to tread carefully here.

    Thanks in advance for any help you can give me.
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
  3. davids355 thread starter macrumors newbie

    Joined:
    Apr 12, 2018
    #3
    Thanks for the reply, really appreciate it.

    However, I ended up loading a fresh install of sierra (I was still getting the error about there not being enough free space so I had to delete all partitions on the drive, then format with disk utility to mac OS extended (journaled), then the install succeeded.

    Then after the install it asked me if I wanted to restore data, so I put in the timemachine backup and restored apps and data.

    Now its fully upgraded to latest OS version, and all the data and apps are back on as well.

    This is so hard for me, because I am used to windows, but if it werent for the fact that I know so little about macs, i definitely think it would be easier - its a dream being able to move applications so easily between one install and another - you cant do that on windows, thats for sure!!
     

Share This Page