Problem using Epson R260 on Leopard via Airport Extreme

Discussion in 'macOS' started by treehorn, Nov 9, 2007.

  1. treehorn macrumors 6502

    treehorn

    Joined:
    Aug 21, 2007
    #1
    Having an odd problem. I have an Epson R260 (which is a problem all to itself, but that's another thread) which I have hooked up to an Airport Extreme. It prints w/o problems via Airport when I use my laptop that is still using Tiger, but I can't get it to print via Airport using the IMac that I upgraded to Leopard.

    The odd thing is that if I hook up the printer directly to the IMac (which is using Leopard), it prints with out problems.

    The printer appears in Printer Setup w/o problems. It shows up in the Airport Utility as being hooked up to the Airport Extreme. And as I said, it works when I hook it up directly to the IMac (indicating it isn't a driver incompatible with Leopard), and when I print using another laptop (indicating it's not a problem with the Airport Extreme).

    Makes me think there's a setting I need to tweak in Leopard to allow me to print using Airport, but the Help documentation hasn't provided any obvious answers.
     
  2. IzzyJG99 macrumors 6502

    Joined:
    Oct 26, 2007
    #2
    Some printers just don't work with the Airport Express/Extreme. I've got friend who've bought HP's, Lexmarks and Epsons and some of them just will not work over Airport Express/Extreme. Epsons have (I've had four since I got my AirEx) and they have never worked right over the Airport Express. Either they'll work, but I can't access anything on the printer with the Printer Utility (Clean print heads, etc) or it just flat out wont work.
     
  3. treehorn thread starter macrumors 6502

    treehorn

    Joined:
    Aug 21, 2007
    #3
    As I mentioned, though, the printer does work w/Airport Extreme. It worked perfectly under Tiger. (and still does on the computer still running Tiger)

    (and on another topic, I don't think it's possible to use Printer Utility via Airport. I think it the printer has to be connected to the computer directly for it to work...or at least that's always been the case with any of the 5 printers I've used w/Airport)
     
  4. osborda macrumors newbie

    Joined:
    Jun 26, 2007
    Location:
    Nashville, TN
    #4
    I'm having the exact same issue, except my printer is the Epson R380. This printer worked fine with Tiger via Airport Extreme.
     
  5. thelord82 macrumors newbie

    Joined:
    Nov 25, 2007
    #5
    Same probleme here. My printer is the HP OfficeJet K550. It worked absolutely perfectly on Tiger on my MacBook Pro. On the Imac, nothing to do!! :mad:
     
  6. dmeakin macrumors newbie

    Joined:
    Jan 10, 2006
    #6
    I have exactly the same problem, using a Lexmark X75 on my PowerBook G4.
    It used to work before I installed Leopard.

    I hope someone will come up with a solution.
     
  7. bponder macrumors newbie

    Joined:
    Dec 28, 2007
    #7
    Epson R260 problem appears to be a Leopard problem

    I have the exact same symptoms with my Epson R260. I've called Epson, who said call Apple. I went to the Genius Bar (someone at Apple has a sense of humor) and they said it is an Epson problem. However, if people are having the same "Communication error" problem with Epsons, HPs and Lexmarks, and maybe others who haven't matched up with this thread, then it's pretty sure it's an Apple problem. Does anyone know of a way to escalate this to Apple as a BUG? I'll go looking but I haven't found a way in past forays.

    The Gutenprint driver supplied by Apple works "sort of" if you need rough drafts. But paper alignment is off and print quality, like for photos, is unacceptable.

    There is a newer Gutenprint driver (5.0.2) that appears to solve most of the problem. The print quality is much improved but the alignment for borderless printing is still a little bit off. Go to http://gimp-print.sourceforge.net/MacOSX.php3 and download the new driver. The disk image includes an uninstaller. Delete the existing print queue (System Preferences - Printers and Fax). Run the Uninstaller to remove the old Gutenprint drivers, then install the new ones and reinstall the printer, selecting the Gutenprint driver and try it. It'll do 'til Apple gets the OS fixed.
     
  8. xserveG5.PB.G4 macrumors newbie

    Joined:
    Dec 8, 2006
    Location:
    Doylestown, PA
    #8
    Same Issue only Sometimes I can Print Using Airport

    We have had a wireless Network for at least five years, Linksys, WPA, and this year I added an Airport Express so everyone in the house could print on our Canon Pixima 4300 (free with one of our Macs). The only computer that now can print, is my wife's G4 eMac which is running Tiger. None of the laptops, 3 running Leopard (2 Intels and one G4) and one running Tiger(G4) can print, but it wasn't a problem until the last couple months.

    Coincidentally,my Powerbook G4 and MacbookPro both have been losing internet signal, and I have to rejoin the network maybe once a week.

    I tried everything, updating the Airport Express firmware, wiping it out and reinstalling the firmware. One thing worked,

    Restarting the Airport Express from the eMac (use the Airport Utility). This worked after resetting (pushing a paperclip end into the small button) - then everyone can printer for a while, but after a week or so, it just stops. If it works for anyone else, please post. :confused:
     

Share This Page