iPhone Problem Using LS Themes

Discussion in 'Jailbreaks and iOS Hacks' started by davidnyjets, Mar 13, 2013.

  1. davidnyjets, Mar 13, 2013
    Last edited: Mar 13, 2013

    davidnyjets macrumors 6502

    davidnyjets

    Joined:
    Feb 4, 2011
    Location:
    Stamford, CT
    #1
    Having an issue with any LS I use. Currently have Peekly, but it happens with whatever LS is choose via Winterboard.

    What I can't seem to figure out is why when I am playing music and have my screen locked (while using any custom LS) my status bar is weird. I've attached a screenshot to show you.

    Also, it seems that using any LS theme will mess up my phone app. Same with the photo app. I've attached pitcures of those issues, too.

    Does anyone know how to fix these issues? Thank you!
     

    Attached Files:

  2. Resante macrumors member

    Joined:
    Sep 18, 2012
    #2
    Just looks like there is a transparent status bar background file in either the themes or default apple folder. Not in a position to check file locations right now but I'm sure someone will come along shortly.
     
  3. davidnyjets thread starter macrumors 6502

    davidnyjets

    Joined:
    Feb 4, 2011
    Location:
    Stamford, CT
    #3
    I think you're right. I just restored, updated to 6.1.2 and then rejailbroke and still the same problem. Weird.

    I'm using same LS and downloaded basically all the same apps/tweaks. That's including iFile.

    Anyone know where I can located that file mentioned above and how to rectify the problem?
     
  4. cubian macrumors regular

    Joined:
    Dec 20, 2010
    #4
    Try this use ifile and goto the Ls theme folder remove all file in the uiimage folder then respring this should give ur org status bar back
     
  5. davidnyjets thread starter macrumors 6502

    davidnyjets

    Joined:
    Feb 4, 2011
    Location:
    Stamford, CT
    #5
    Problem is that it is happening with any LS theme I use. I think I might've edited the file for the entire iPhone.

    I can't even remember if this is the default status bar look. Here are some pictures.

    As you can see, it's transparent everywhere!
     

    Attached Files:

  6. davidnyjets thread starter macrumors 6502

    davidnyjets

    Joined:
    Feb 4, 2011
    Location:
    Stamford, CT
  7. JPNFRK7 macrumors 6502

    JPNFRK7

    Joined:
    Sep 27, 2012
    Location:
    California
    #7
    I dont see Peekly in Cydia, but it does seem like the theme has a transparent status bar in the UIImages folder within the theme. The problem with iOS6 is that is makes use of the transparent status bar in a lot of apps. What you need to do is (if you want the stock status bars back but want the theme enabled still):
    On the Phone:
    - Install iFile
    - Navigate to your theme (var/private/stash/theme.xxxxx/"your theme"/
    - Navigate to the UIImages folder within the theme and delete the file "Translucent_Base@2x.png"
    - Open Winterboard and reapply theme and respring.

    On computer:
    - Download a file explorer or SSH client and open up the iPhone filesystem (ie: iExplorer)
    - Follow steps two and three above.
    - Go back to phone and open Winterboard
    - Reapply theme and respring

    If the theme is easy to get and apply, just delete the file from the theme. If this is a theme that you probably couldn't get again, back the file up to something like /var/mobile/Documents.

    Edit: If you only want transparent status bars on the Lockscreen and Homescreen. There are many ways to do this but I downloaded "Flex" from Cydia and installed the two tweaks called "Transparent Status Bar Only on Lockscreen" and "Transparent Status Bar Only on Homescreen"

    Hope this helps
     
  8. davidnyjets, Mar 13, 2013
    Last edited: Mar 13, 2013

    davidnyjets thread starter macrumors 6502

    davidnyjets

    Joined:
    Feb 4, 2011
    Location:
    Stamford, CT
    #8
    I tried this and I'm not sure anything is different. I think I did something a few weeks ago with the Apple status bar file/image. Where would that be?

    By the way, thank you so much for your help.
     
  9. JPNFRK7 macrumors 6502

    JPNFRK7

    Joined:
    Sep 27, 2012
    Location:
    California
    #9
    The Original file is located in a file called UIImages that is I believe hard to open and compress again. What other themes (if any do you have any)are activated in Winterboard? If it is only this theme, then you might have messed something up. If you have other themes use the same steps above and look in the UIImages folders for anything with the names "Transparent_Base@2x.png", "Silver_Base@2x.png" or "Black_Base@2x.png". Something along those names. If you do see something like these they were probably changed to be "transparent" and need to be deleted or changed. If you do find these files, move them to the /var/mobile/Documents just to see if they do anything. If something is messed up replace them.

    Last thing, did you go into Winterboard and respring? The only way I have been able to get themes to refresh is to go in and double hit the top theme and then go back and hit respring. The respring utilities in NCsettings or other tweaks dont change the files that Winterboard does.

    Report back.
     
  10. slumpey326 macrumors 6502

    Joined:
    Jun 18, 2010
    Location:
    Florida
  11. davidnyjets, Mar 14, 2013
    Last edited: Mar 14, 2013

    davidnyjets thread starter macrumors 6502

    davidnyjets

    Joined:
    Feb 4, 2011
    Location:
    Stamford, CT
    #11
    Yesterday I restored my iPhone to the newest version (6.1.2) and rejailbroke. I then used a backup from iCloud. Is it possible whatever tweak or edit I made is being restored from that backup?

    I just restored and setup as a new phone. Then I jailbroke and am now installing all my apps back. I downloaded Winterboard and SSHed in the peekly LS. It is an issue with the LS. I'm going to see if other LS have the same issues now.

    Hopefully they won't.
     
  12. JPNFRK7 macrumors 6502

    JPNFRK7

    Joined:
    Sep 27, 2012
    Location:
    California
    #12
    If this is the only LS theme you have then it is either the theme itself or a tweak that is changing the Status bar. Bummer you had to restore to try and fix this. If I cannot find the solution to something, I usually restore and install every tweak I had one by one to see which one it was. I honestly think it is your LS theme. If you can, could you link me to where you got the theme and maybe I can make it work. Also if you are looking for a minimalist LS that doesn't change the Status Bar download Glasklart and only use the LS part of it.
     

Share This Page