Problem using quicktime to watch .mov videos

Discussion in 'Mac OS X Lion (10.7)' started by jtomasrl, Jun 12, 2012.

  1. jtomasrl macrumors newbie

    Joined:
    Jun 12, 2012
    #1
    I've downloadeda lynda.com videos and when i double click on them I cant watch them with QuickTime 10.1, but I can watch them using Preview, on QT the screen is shown but i cant hit on play and in Preview i get image and sound working fine.
     
  2. Sylon macrumors 68020

    Sylon

    Joined:
    Feb 26, 2012
    Location:
    Michigan/Ohio, USA
    #2
    When you double click on the file, does QT open up at all? Does it open, then just doesn't play the video?
     
  3. jtomasrl thread starter macrumors newbie

    Joined:
    Jun 12, 2012
    #3
    QT open and shows the video but doesnt play it
     
  4. Sylon macrumors 68020

    Sylon

    Joined:
    Feb 26, 2012
    Location:
    Michigan/Ohio, USA
    #4
    I have that problem with a few of my videos, specifically any video I render thru Adobe Premiere oddly enough. I've learned that, at least in my case, its not that QT can't play the file, it's struggling to get it started.

    I'm not sure how to fix it, but I do know a couple work arounds. First, before you open the file, start the video in preview by pressing play on the file icon. Then, a few seconds in, double click on the file. QT should open and pick up where it left off. You may have to hit pause on the icon playing in preview, otherwise you'll have it playing twice at the same time.


    Another way I've found is to run it thru a video converter. Using a converter like Handbrake or something similar has fixed the video and QT plays it well.

    Lastly, you could try playing the file with a different media player, like VLC.
     
  5. jtomasrl thread starter macrumors newbie

    Joined:
    Jun 12, 2012
    #5
    i tried vlc and played it without sound. i downloaded some video codecs and didnt work, neither do divx video player. but i can watch it on QT for windows
     

Share This Page