Problem with 4th gen 20 GB iPod

Discussion in 'iPod' started by CousinIt, Mar 12, 2007.

  1. CousinIt macrumors newbie

    Mar 12, 2007
    Hi :)

    I sorta "inherited" a 20 GB, 4th generation iPod from my brother after he bought the 30 GB video. Unfortunately, when I connect the iPod to the PC, it will charge OK, which indicates the battery is fine, but neither my PC nor itunes will recognize it. Instead, after charging, I get a folder with an exclamation sign icon.

    I have visited the support section on the Apple website and verified that the iPod is fully charged. I have reset several times, but I don't know how I can 'restore" if my PC won't recognize the iPod. Frankly, the support section is starting to annoy me as it feels more like I am reading a "Chose Your Own Adventure" book.

    Cutting to the chase, I really want to keep this particular iPod, it being a 20 GB and all [I have TONS of music], but I am outside the US. Would anyone here know why my iPod is doing what it is doing and is it worth it to send it to be repaired in the US? Is there something I could do to fix it? Anyone else had something similar happen with their iPods?
  2. MacAnkka macrumors regular

    Jun 30, 2006
    Why would you have to send it to the US for repairs and where do you live? There are official Apple service centers in most of the countries in Europe and I guess in most of the other parts of the world, too. I'm sure there are also other stores/repair shops that would be willing to repair your iPod, even if they arent certified by Apple.
  3. CousinIt thread starter macrumors newbie

    Mar 12, 2007
    I am in the Caribbean and I don't know how much I trust service centers here. I was hoping, however and given how shady and/ or expensive these centers here can be, someone would be able to give me an idea of what the problem could be and how much it would cost to fix it or if there are ways to fix it yourself.
  4. California macrumors 68040


    Aug 21, 2004
    Cousinit: I'd buy a new iPod 40 gig (it will fit) hard drive and install it myself as per the instructions on the ifixit site. Your hard drive is dead, that is why you are getting the question mark. The 4th gen iPods came with both 20 and 40 gig hard drives; so upgrade while you are at it.
  5. CousinIt thread starter macrumors newbie

    Mar 12, 2007
  6. sonofjabba macrumors member

    Mar 10, 2007
    Your computer might not have a USB 2.0 Port, and I have found some Intel chipsets for USB 2.0 don't recognize the ipods properly (Syncing Problem, Not Recognizing the pods, Not mounting the pod, slow mounting the pod.. ETC), and the only good cheap solution is to try a USB 2.0 Belkin card. They work good in Macs too BTW. Or in the case of the 4th Gen Try it through a firewire connection. A folder with an Exclamation point is generally a software problem, also try putting it into Disk mode and connecting it to the sync cable.

    Some other problems might be the battery is starting to go. Those 4th gen Batteries are now 3 or 4 years old. And Ion Batteries are strange you can have one last 5 or 6 years and others last only a year before they start to deteriorate. And wiggy batteries can make ipods go completely stupid.
  7. mattibek macrumors member

    Feb 16, 2007
    Lexington, KY
    Try this first

    You might have a corrupted hard drive... but you might be able to fix it.

    I did this on a Mac and don't know PC opperation but if you fix it on a Mac and then switch it back. Or figure out similar trick with PC.

    1) Put ipod in Disk Mode by pressing enter+play at same time.

    2) Connect to Mac via firewire cable.

    3) You should get a meesage that says disk cannot be recognized. Choose initialize disk.

    4) Try to Repair Disk first, but if your ipod is like mine was then go to erase function, go to erase options and set write to 0's, select your disk volume and erase. A message will appear warning you that erasing an ipod will disable some functions. Don't worry, it fixed mine.

    5) This will take an hour.

    6) Now open itunes and hopefully it should be recognized.

    7) Select restore.

    Hope this works. Let me know if you have any Q. about my poor directions and good luck. It worked great on mine and I've tried everything, and thought it was toast. Be persistent and try everything you can find online before spending money for something you might be able to fix yourself.
  8. Chef Medeski macrumors 6502a

    Chef Medeski

    Jun 14, 2005
    New York, NY
    Had the exact same thing happen to me. When it wont be recognized by the computer that means that the HD is not functioning accurately. Two problems inherent in that. The HD is bad. Or the connection is bad. In my case the connection was bad. What do you do? Pop open the iPod press firmly down on the connection to the HD, lift up the HD, gently lift tape. Gently push end of connector into slot. If your HD starts whirling up. Well then you got lucky it was merely the connection. If nothing still. Then your HD is toast. IN which case a new HD would be in order.

    Try the cable first though. I bought an extra HD. Went in to change it and what! All I had to do was press down on the cable. Silly me. Now Im stuck with an extra HD. Ahh... Its so easy to swap, I could use it as two iPods.

Share This Page