Problem with 5.1 sound on 4th gen Apple TV

Discussion in 'Apple TV and Home Theater' started by iamloco724, Dec 28, 2015.

  1. iamloco724 macrumors newbie

    Joined:
    Sep 16, 2013
    #1
    After the most recent update I no longer have 5.1 sound on the WWE Network. I had it before that and since I bought the Apple TV. Im not sure how to fix this or if I can. Is there anyway to roll back to the previous firmware?
     
  2. Gueeds macrumors member

    Joined:
    Jul 29, 2015
    #2
    WWE network has always been stereo. You had your setting set to Dolby in the audio settings and that was incorrectly sending 5.1 DD regardless of the source.

    No issue, working as intended.
     
  3. iamloco724 thread starter macrumors newbie

    Joined:
    Sep 16, 2013
    #3
    While I thought that was the case, my receiver showed 5.1 and since the update there is a noticeable difference in how it sounds even the volume in which I watch the programs are different then what I had to have them set at it before the update. So it might not have been actual 5.1 sound but something definitely changed in the sound I heard the difference right away thats why I checked my receiver to see what it was reading. And I prefered how it sounded before it its hard to describe but it sounded less harsh and more leveled.
     
  4. Gueeds macrumors member

    Joined:
    Jul 29, 2015
    #4
    It's coming over as PCM 2.0 stereo instead of DD. When Dolby Digital is sent to a receiver, it has an offset value which boosts the volume level.

    I set my receiver to matrix out 2.0 sources so I get 5.1. It may be possible you have some additional compression enabled or dynamic range clipping on your receiver that kicks in on stereo sources. Hard to say without seeing it.
     

Share This Page