Problem with a damaged file and deleting it

Discussion in 'Mac OS X Lion (10.7)' started by joshlikesbagels, Dec 25, 2011.

  1. joshlikesbagels macrumors newbie

    Joined:
    Dec 25, 2011
    #1
    I have a 2010 Macbook Pro, running Lion.

    My issue lies in one file that really doesn't want to be deleted.

    I moved some space-hogging games onto my external hard drive to free up space, only to find that it simply copied the .app into the hard drive. No matter, I just sent the local .apps into the trash and attempted to delete. No luck running the empty trash. I deleted items one by one until I was left with the offender .app. It seems to be my sims3.app file.

    When I try to load it up, i get a message telling me that "You can't open the application The Sims3 because it may be damaged or incomplete,"

    When I do try to empty the trash, it says preparing to empty trash; items to delete: 0 and never loads anywhere, even after being left for hours. If I try to stop the empty, same thing, nothing happens. It just says stopping. I've tried all sorts of sudo commands, but nothing has worked.

    Can anyone help me out and see what I can do about this pesky file?
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    OK:
    1. Launch the Terminal.
    2. Type "sudo rm " without the quotes but with the space after the m.
    3. Drag your troublesome application to the Terminal window.
    4. Press [return].
    5. When prompted, authorize with your Administrative password.
    6. Press [return].
    In the immortal words of Jerry Pournelle: "Bob's your uncle."
     
  3. joshlikesbagels thread starter macrumors newbie

    Joined:
    Dec 25, 2011
    #3
    I tried EXACTLY as you said, despite having tried very similar commands before and got the same result.

    At the point where the file would presumably be deleted, I get the message " rm: /Users/Josh/.Trash/sims/The Sims3.app: is a directory" I checked, and the file is still there. Worried that it was because it was in my trash, I tried the same thing, but with the file on the desktop. Similar results : "rm: /Users/Josh/Desktop/The Sims3.app: is a directory" :confused:
     
  4. xlii macrumors 68000

    xlii

    Joined:
    Sep 19, 2006
    Location:
    Millis, Massachusetts
    #4
    in the terminal window type:

    cd Desktop

    man rm (will tell you what the command does).
    man rmdir (will tell you what the command does).

    rm -r name_of_your_file should work. You need to be careful with these command so read the descriptions above before using.
     
  5. joshlikesbagels thread starter macrumors newbie

    Joined:
    Dec 25, 2011
    #5
    xlii I don't really know what you had me do that was really different from what anyone else had me do, but it worked!!!! However, simply typing the name of the file didn't work, but I dragged it into terminal and that did the job.

    Oh, and thanks for the manual guides; I didn't even know they were there.

    Thanks a million!!!
     
  6. vevelye macrumors newbie

    Joined:
    Apr 30, 2012
    #6
    Same issue

    Hi, I'm having the same problem with my spotify.app file which is incomplete and damaged. I am not having success removing it. Can someone walk me through the steps again? Are the commands quoted in earlier thread the same for any file or is it commands specific to joshlikesbagels file?

     
  7. MadameMeow macrumors newbie

    Joined:
    Dec 3, 2012
    #7
    Hello,

    I am having problems with a corrupt Spotify app and I tried what you all suggested, but the thing is still staying put. Any help at all would be appreciated.

    Thank you.
     
  8. winner200 macrumors newbie

    Joined:
    May 3, 2013
    #8
    Same problem

    There is an application called "Vuze" which cannot be opened because it says that it is damaged or incomplete. I have tried and deleted all folders related to Vuze successfully, but the main application is just not getting deleted! It is freaking me out and I don't know what to do! PLease help!
     
  9. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #9
    Three steps:
    1. Read Post No. 2 of this thread.
    2. Follow instructions.
    3. There is no Step 3.
     

Share This Page