Problem with a iMac G3

Discussion in 'PowerPC Macs' started by neuro16, Jun 11, 2008.

  1. neuro16 macrumors newbie

    Jun 11, 2008

    I have a G3 iMac that had a bad hard drive and a bad cd rom, I replaced both and the computer now "works". Tried to install os 8.5 and it went through an installation process, but will only boot off of the disc, even though the hard drive seems to have all of the appropriate files and folders installed on it. What did I do wrong/how can I fix this? Any response is appreciated.

  2. brop52 macrumors 68000


    Feb 26, 2007
    First of all, which HDD did you get? ATA133/100 IDE 7200 RPM? You can only see 120GB of a hard drive if it is the slot loading model. You didn't switch around any of the jumpers did you? In general they are usually set correctly.

    The problem you are probably having is formatting with disk utility. Make sure you format the HDD with disk utility as HFS+

    System 8? These machines aren't meant to run system 8. They came with system 9. Make sure the firmware is up to date and get a copy of Tiger if you have upgraded your RAM too. Unless is the tray loading iMac which in that case you may be better off sticking with 10.3.
  3. neuro16 thread starter macrumors newbie

    Jun 11, 2008
    It is a tray loading model, and I believe the hard drive is only 20 gigs, so that is not an issue. I also did not touch the jumpers.

    As far as formatting, all I did was put in the CD and followed the instructions from there, I do not believe I had an option for special formatting. If I did not follow the correct procedure can you help put me in the right direction please?

    Thank you for the response.

    Edit: When I tried to put 10.x (I believe it was 10.3) on it, the window that came up said that it could not load the disc image, and to select another one. Was that just a bad disc or ?

Share This Page