Problem with actual magnetic tip of MagSafe?

Discussion in 'MacBook Pro' started by TheMBC, May 4, 2012.

  1. TheMBC macrumors 6502

    Joined:
    Jun 14, 2008
    #1
    Hey, I did a quick Google and Forum search but didn't really find my exact problem. The actual magnet to my L-Shaped MagSafe isn't really attached to the charger anymore. It just happened one day — I unplugged the charger and then realized that the magnet was still stuck to the laptop. I can get the magnet out of the jack by inserting the charger and removing it quickly (which keeps the magnet on the actual MagSafe), but this is a less than ideal situation.

    Everything I found was about actual tears or rips with the charger rather than this. Perhaps someone here can point me in the right direction of how to go about fixing it. Any help is greatly appreciated! :D

    I attached an image so you can understand what I meant.
     

    Attached Files:

  2. Virgule82 macrumors newbie

    Joined:
    Mar 15, 2012
    #2
    Either get it exchanged for a new one at the Apple store or just use some glue to attach the magnet properly. Shouldn't be a problem
     
  3. TheMBC thread starter macrumors 6502

    Joined:
    Jun 14, 2008
    #3
    Thanks! I was thinking of using glue but wasn't sure. Will have to be extra careful if/when I do it :)
     
  4. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #4
    Glue should work fine, but it's not going to be a permanent solution. I'd exchange it for a new one.
     

Share This Page