Problem with AirPods Pro and MBP16

gtjeta

macrumors member
Original poster
Mar 31, 2012
66
31
My AirPods Pro work perfectly with iPhone, two iPads and Apple Watch. But with MBP16 they disconnect every 5-10 seconds, or stop playing music even when connected also in a few seconds. I removed Bluetooth.plist and restarted NVRAM, it worked ok for 15 minutes and it is messed again. Any idea?

It is a pity, this is the only thing not correct for me in this awesome computer.
 

icloudUser

macrumors regular
May 20, 2019
208
71
Mine work well with the MBP (also 16"). No Issues whatsoever. Connection is stable both while streaming and listening to downloaded track
Ringing Apple support could come handy here
 

gtjeta

macrumors member
Original poster
Mar 31, 2012
66
31
It seems with the new macOS update it got at least partially sorted out. Some glitches, but in general correct.

Now I have problems connecting an iPad through Bluetooth. My feeling is Bluetooth support in the MBP is quite bad/unstable with Catalina.
 

swandy

macrumors 6502
Oct 27, 2012
458
96
This is interesting. I had the same issue as you but with my Apple Watch Series 4. No issues with iPhone 11, iPad mini 4 or iMac. Did the recent updates after talking to Apple Support and it seems better BUT when I was trying to solve the issue, resetting the Watch, or unpairing and repairing the Watch (either a restore from backup or as new) solved the issue for about 4-5 days and then it would start all over again. So not sure whether to keep the appointment at the Genius Bar or wait a few more days. Gotta love technology!