Problem with an app update

Discussion in 'iPad Apps' started by martosprint, May 3, 2011.

  1. martosprint macrumors 6502

    Joined:
    Jun 1, 2010
    Location:
    Florida
    #1
    Two weeks ago I downloaded an app "the civil war today" and it worked. A few days ago there was an update for that app so I go into iTunes to update it from there cause I don't have wi-fi at home and the update was over 20 MB. The app wouldn't update, it just said loading. I tried some of the solutions and it didn't work. Finally I called Apple iPad tech support and for 3 days of trying to resolve the problem nothing worked. The icon remained on the iPad saying "loading." One advisor had me remove all the apps, then sync them back onto the iPad. That didn't work, so the next day I called tech support again and the guy had me restore to factory settings. That didn't work either. My apps were no longer in folders of course and I had to create new mail accounts. It was a hassle. The last tech put me in contact with a supervisor, and I told him we tried everything to remove the app icon from the iPad to no avail. I told him I wasn't about to go thru all that stuff again to restore to factory settings because it was such a hassle and it didn't work the first time. Well the supervisor and I tried a few other things to even just remove the app. No joy, well I requested a refund for the app which was about 8 bucks and he started the process. The app wouldn't load and couldn't be removed. I just stuffed the loading app into a folder so I wouldn't have to look at it anymore. By the way the iPad works fine. Tech support did it's best but could not understand after all the trouble shooting why the app wouldn't update nor be removed from the iPad. I spent about 4-5 hours talking on the phone with various advisors. 
     
  2. cteselle macrumors newbie

    Joined:
    Jul 18, 2010
    #2
    Once you connect to a wifi network the app should download properly, as this just happened to me. I would also imagine that if you updated the app via iTunes and then sync, the issue would fix itself.
     
  3. martosprint thread starter macrumors 6502

    Joined:
    Jun 1, 2010
    Location:
    Florida
    #3
    Thanks for the reply but none of this worked with the coaching from several Apple techs. 
     
  4. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #4
    3 things:
    1) Update the app on the computer and sync your iPad. Should update it without a problem. Happens to me all the time and this is a fix.
    2) if you are running 4.3+ you can hold the icon app till it wiggled and there should be an X to delete the app. Then just reinstall it when you have WiFi.
    3) as another person mentioned connecting to wifi should start the update process. If not then turn wifi on. Turn off the iPad completely. Turning it back on should ask for your iTunes password and it will update.

    None of these have every failed me.
     
  5. martosprint thread starter macrumors 6502

    Joined:
    Jun 1, 2010
    Location:
    Florida
    #5
    The 4 techs couldn't get it to work after trying everything possible. Making all the icons wiggle okay but an x never appeared on the app to delete it. I'm telling ya, we tried everything but to no avail. Thanks for the reply. 
     
  6. evalynne macrumors newbie

    Joined:
    May 12, 2011
    Location:
    Boulder Creek, California
    #6
    Same issue as OP

    I am having the same problem. I purchased the app Pages from my iPad over 3G and it stuck at loading...

    I've downloaded to PC and tried syncing, deleted, reset the iPad, tried everything listed here and more but still the "Application Over 20MB" message pops up and the app won't reinstall, icon remains at loading and app is not usable. On my PC in iTunes, the display of my iPad apps shows both the icon in its loading state *as well as* another icon that is correct--but that's not the actual state of the iPad. Only the 'broken' icon is visible :(
     

Share This Page