Problem with Auto Reconnect of SMB Drives

Discussion in 'macOS' started by t4ttyt3ddy, Aug 11, 2009.

  1. t4ttyt3ddy macrumors newbie

    Joined:
    Aug 11, 2009
    #1
    Hi

    I have a user who has a new Macbook Pro 17".
    We have 2 samba shares that he needs to connect to.
    If I use cmd + k and then select the drive and click connect it connects fine.
    The problem is that it doesn't reconnect at logon or wake up.

    I have tried putting it in the users startup items but that hasn't worked.

    I am a Windows guy and find it very frustrating that things that should work on a mac aren't working! I have googled it and all the answers seem to be the above(Which I have tried!).

    If anyone could offer me assistance on this that would be great.

    Thanks
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    i just tried putting my smb volume in Login Items as shown below and it works fine.

    Picture 1.png

    problem is a Finder window opens before it connects creating a folder in /Volumes called "share-1" (and then next time "share-2" will be created) and then the share Finder window opens and you cannot hide these Finder windows by ticking "Hide". its not good an easier should be option.

    but your samba server should appear in the Finder sidebar on login and you just click on that then the volume to connect.

    OS X can mount NFS volumes on login if that is of any help in Directory Utility under Mounts (first need to enter credentials and show the toolbar).
     
  3. scienide09 macrumors 65816

    scienide09

    Joined:
    May 5, 2007
    Location:
    Canada
    #3

Share This Page