Problem with auto-spelling correct

Discussion in 'Jailbreaks and iOS Hacks' started by newrazr, Sep 1, 2010.

  1. newrazr macrumors member

    Joined:
    Aug 8, 2010
    #1
    Not sure why but all of a sudden for the last 2 days, the ios auto-spelling correct feature keeps changing the word "me" to "mr". I don't want to turn the feature off because it's useful for correcting all my other mistakes but that one is really annoying because I never use "mr" (all lower case) and often use "me"

    Does anyone know how to edit the "dictionary" its using to make the corrections. I've got a jb ip4. It's been jailbroken for awhile and this problem is only recent so I know it's not tied to having just been jailbroken.

    Thanks.
     
  2. psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
    #2
    I've had this problem for a while as well. Some other bad ones for me are not correcting "dint" to "don't" (is dint actually a word:confused:?) and "fir" to "for". I know fir is a word, but really:mad:? Who the heck uses the word fir in a text message? I'm shocked that nobody has come up with a way for us to edit the dictionary manually. This is actually something that Apple should allow natively but we all know how that goes. I would guess that there has to be a way for us to edit the dictionary somehow but I haven't seen a utility for it yet.
     
  3. lansa macrumors member

    Joined:
    Jul 1, 2010
    #3
    Yes, the fir correction is a killer! Happens to me several times a day, so annoying.
     
  4. Sirolway macrumors 6502

    Joined:
    Jun 13, 2009
    Location:
    London
    #4
    I get it changing 'me' to 'mr' all the time - no matter how many times you confirm you want 'me,' it never seems to learn..

    Judging by one of Stephen Fry's posts a while back, he gets this too ..
     
  5. psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
    #5
    Is there a way to access the dictionary with ifile or via SSH?
     
  6. newrazr thread starter macrumors member

    Joined:
    Aug 8, 2010
    #6
    Exactly... Anyone have any ideas on how to SSH into the dictionary file? Any help would be appreciated.
     
  7. Maverick1337 macrumors 65816

    Maverick1337

    Joined:
    Nov 4, 2008
    #7
    I remember back in the day I believe before 3.0, it would auto-correct "o" to "I" which I loved now it doesn't do that anymore.
     
  8. doboy macrumors 68000

    Joined:
    Jul 6, 2007
    #8
    I would suggest resetting the dictionary and start building a fresh one. "Me" works fine on my iPhone 4, 4.0.1 JB.
     
  9. newrazr thread starter macrumors member

    Joined:
    Aug 8, 2010
  10. doboy macrumors 68000

    Joined:
    Jul 6, 2007
    #10
    Settings->General->Reset->Reset Keyboard Dictionary
     
  11. newrazr thread starter macrumors member

    Joined:
    Aug 8, 2010
    #11
    Thanks but unfortunately that didn't solve it. Not sure why it's happening but hopefully someone will have some insight into how to SSH into the dictionary file.
     
  12. Palomonkey71 macrumors newbie

    Joined:
    Sep 1, 2010
    #12
    They should have just made it do that you could customize words in the dictionary and add others so that it won't auto-correct
     
  13. B737 macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #13
    check your phone book!
    i had a contact in my phone book that started with Mr. and i think the spell check was referencing that, once i deleted that and reset my dictionary it went away. really annoying...
     
  14. newrazr thread starter macrumors member

    Joined:
    Aug 8, 2010
    #14
    That was it!! I removed the Mr from the beginning of the contact, reset the keyboard dictionary and then rebooted the phone and thankfully it's all about "me" once again;). Thanks for the help.
     

Share This Page