Problem with Bootcamp partition

Discussion in 'Windows, Linux & Others on the Mac' started by Kreynor, Feb 17, 2012.

  1. Kreynor macrumors newbie

    Joined:
    Jul 19, 2011
    #1
    Hello everyone.

    I have been using Windows 7 on my iMac with Bootcamp for quite some time now.
    Today I created a second partition on my hard disk but seems like this messed up Bootcamp.
    I tried to boot from Windows but couldn't. So I deleted this new partition and resized the hard disk like nothing happened.
    Tried to boot again from Windows but got the same problem. While I was resizing the hard disk I read something in Disk Utility that basically meant "if you modify the partition, bootcamp may not work".

    So.. how can I fix it? Because right now the only solution I know of is to erase Bootcamp and start again from scratch.

    Thanks.
     
  2. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #2
    It sounds like your MBR and GPT partition tables are quite probably out of sync. You could trying installing rEFIt and running gptsync to synchronize the two. If that doesn't work you may very well have to start from scratch with Boot Camp.
     
  3. Kreynor thread starter macrumors newbie

    Joined:
    Jul 19, 2011
    #3
    Thanks, that solved it.
    I installed it but didn't work, so I burned it into a CD and booted from it. Worked perfectly.

    Thanks again!
     

Share This Page