Problem with changing volume sound in OS X El Capitan

Discussion in 'OS X El Capitan (10.11)' started by Mpalomba3, Jul 9, 2015.

  1. Mpalomba3 macrumors newbie

    Joined:
    Jan 29, 2014
    Location:
    Staten Island
    #1
    Hi, so I just upgraded to the OS X El Capitan Beta and it's not bad but I'm having one problem. In Yosemite I changed the volume sound back to the original on from Mavericks and every other OS X before it. I tried to do the same thing once I upgraded to El Capitan but it won't let me. No matter what commands I use it just says "Operation not permitted"

    Things I've tried:
    Just deleting it using finder. Result: The operation can’t be completed because the item “volume.aiff” is locked.
    In terminal :
    cd /System/Library/LoginPlugins/BezelServices.loginPlugin/Contents/Resources
    sudo cp volume.iff volume_backup.aiff. Result: Operation not allowed

    sudo chown Michael /System/Library/LoginPlugins/BezelServices.loginPlugin/Contents/Resources Result: Operation not allowed.

    I'm really not sure what else to try but I hate the default volume changing sound in Yosemite and El Capitan. I also tried changing the permissions by pressing Command & i but it just says I don't have permission to do that.
     
  2. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #2
    How to disable Rootless:

    Method 1 (simpler but may not exist in the final release):

    Run this in Terminal and reboot:
    sudo nvram boot-args="rootless=0"

    Method 2 (Apple recommended):
    Boot into Recovery (start up holding down down Command-R until the Apple logo appears), and select "Security Configuration" from "Utilities" on the menu bar. Uncheck "Enforce System Integrity Protection", click "Apply Configuration", click "Apply" on the resulting prompt, and restart. Rootless will now be disabled.
     
  3. surr3a1 macrumors newbie

    surr3a1

    Joined:
    Sep 3, 2015
    #3
    I don't have this problem but another one much bigger: I do not have any sound when pressing the buttons (sound, brightness etc.) Any ideas?
     
  4. gngrwzrd, Sep 27, 2015
    Last edited: Sep 27, 2015

    gngrwzrd macrumors newbie

    Joined:
    Oct 24, 2012
    #4
    None of the ways mentioned previously worked for me. Here's how I had to do it.

    If you're using a bluetooth keyboard, you'll probably need to find a USB keyboard so you can restart into recovery mode.

    -Reboot into recovery OS. (hold CMD+R on restart)
    -Utilities > Terminal
    -run "csrutil disable"
    -reboot; #back to mac os
    -Open Terminal
    -cd /System/Library/LoginPlugins/BezelServices.loginPlugin/Contents/Resources
    -sudo cp volume.aiff volume_copy.aiff
    -sudo rm volume.aiff
    -sudo mv ~/Downloads/volume.aiff .; #change this to wherever you have the old sound you want restored..
    -Reboot into Recover OS. (hold CMD+R on restart)
    -Utilities > Terminal
    -run "csrutil enable"
    -reboot; #back to mac os
     
  5. scottperezfox macrumors newbie

    scottperezfox

    Joined:
    Jul 27, 2011
    #5
    Follow the above instructions from @gngrwzrd. Man, what a hassle.

    In my case, I have to leave the csrutil disabled because I'm using Xtrafinder. Seems to becoming more and more work to get OS X to behave the way we'd like it to.
     

Share This Page