Problem with Cocoa Gui Application on Mac 10.6.4

Discussion in 'Mac Programming' started by pkmk, Apr 13, 2011.

  1. pkmk macrumors newbie

    Mar 30, 2010
    i have a Cocoa gui application that is build using powerpc. Now i want to run it on intel 10.6.4.
    The problem is sometime my gui application on intel 10.6.4 is run perfectly and some time it run but its icon does not appear in Forcequit window and also when i see it in activity monitor then it show it as a process and there is no icon showing for it. Means activity monitor consider it as a background service not a foreground gui application.
    Also in this case when icon is not showing in forcequit and activity monitor my gui application window is showing but when i preform some action using mouse on my gui application then it works prefectly. But when i type any data in text field on my gui application then keyboard does not work.

    I need the solution of this problem. My application work prefectly on power pc. But when i shift on intel 10.6.4 then i have this issue. Means on intel machine 10.6.4 snowleopard some time it run perfectly as a foreground application and some time it run automatically as background application. I am stucking on this issue please help me. thanx
  2. balamw Moderator


    Staff Member

    Aug 16, 2005
    New England
    I don't think anyone will be able to help without some code or at least more details.

    Which version of OS X and Xcode/ProjectBuilder was used for the original PPC code? How about for the Intel code? Does the app run OK on 10.5 on the PPC platform?

    Does a "Hello World!" type Cocoa app work properly using the toolchain you are using have for Intel?

    Any reason you're stuck on 10.6.4 and not using 10.6.7?

    Inquiring minds want to know!

  3. pkmk thread starter macrumors newbie

    Mar 30, 2010
    thanx for reply. I developed this application using xcode 2.4 on powerpc 10.4 version.
    Now i shift on mac 10.6.4. When first time i run my gui application then they ask me to install "rosetta" sotware and i installed it.

    Note: i did not developed it on 10.6.4 i just run it on mac intel 10.6.4.

    Now when i run my application then sometime they run perfectly. And some time they run as a background application and no icon is displayed in forcequit window and activity monitor. But in this case gui window is displayed and i can used the mouse to perform action. But i cannot used the keyboard to enter data in text field. That is the problem.

    Also i run this application using domain controller. I configure a domain. ON each user login i run this application. Now i hope you understand what is the problem
  4. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    Yes. Your application relies on one or more libraries, which are also PowerPC-only, hence the Rosetta requirement. However... there are two limitations you will run into: Intel code and PPC libraries don't mix. Neither do 64-bit applications and 32-bit libraries. Double-check in Xcode that this is not the case.

Share This Page