problem with connection through FTP

Discussion in 'iPod touch Hacks' started by touchkid, Nov 4, 2007.

  1. touchkid macrumors member

    Joined:
    Nov 3, 2007
    #1
    Ok, I've jailbroken my iPod once before using touchfree. I successfully used cuteftp to install the iphone apps. For one reason or anorher i decided to restore my ipod using itunes. Then I jailbreaked again using appsnapp- this time no luck with FTP - it won't connect! Please help! Oh, and cheers to all the devs out there!
     
  2. alana22 macrumors regular

    Joined:
    Apr 12, 2007
    Location:
    Seattle
    #2
    You are using sftp and not ftp, right? Also make sure your touch is not sleeping. Connect to touch ip with l/p: root/alpine, port 22. If that doesn't work I don't know what else to tell you.
     
  3. touchkid thread starter macrumors member

    Joined:
    Nov 3, 2007
    #3
    Cheers I'll check all that, pretty sure it was sftp though
     
  4. MargeSimpson macrumors member

    Joined:
    Oct 4, 2007
    #4
    after some fiddling with applications i couldnt connect through CuteFTP either... then i tried WinSCP (same IP, root/alpine etc as before), and it worked!

    I am thinking perhaps CuteFTP free edition stops working unless you upgrade?
     
  5. touchkid thread starter macrumors member

    Joined:
    Nov 3, 2007
    #5
    Ok thanks. I'm gonna try this tonight and post back my results. :)
     
  6. dellavoce macrumors regular

    Joined:
    Oct 14, 2007
    #6
    I think you may have nailed it. All of the sudden I couldn't connect with CuteFTP either. I attributed it to a recent change of wireless routers, but as soon as I installed WinSCP, I was able to connect again.
     
  7. touchkid thread starter macrumors member

    Joined:
    Nov 3, 2007
    #7
    ok lol i'm kinda new to winscp, with sftp whats the "private key" box for?
     
  8. yanks4sure macrumors newbie

    Joined:
    Aug 3, 2007
    #8
    I have tried winscp, filezilla, and cuteftp. No Luck...

    PLEASE HALP
     
  9. goldypoker macrumors member

    Joined:
    Oct 26, 2007
    #9
    I may be able to help here....at least, I nhope so.

    Two parts to this...one for people who have successfully done it before, then re-jailbroke, and were having trouble accessing the second time around.

    The other part for people that are trying to access the first time after a jailbreak...sorry, this is for PC only....obviously, if you are using winSCP,lol

    First part,............ I also did the same as the OP, re-jailbroke, but couldnt re-access my touch with either winSCP or CuteFTP using the same passwords and procedures I had successfully used before to install the iphone apps. I kept getting a message which essentially stated that "my keys had changed", this was after re-attempting access a few times. The solution was to tell the program to trust the new keys. Apparently, when you re-JB, it screws with the original connection keys that the access program uses to identify/pair/authenticate a connection with your touch...just tell it to trust/use the new keys and you will be fine. You only need to do this once, it should be clear sailing from there....hope that helps. I think this might be the problem, because some of these posters which tried a new program were then succesful...thats because the new program never "bonded" (generated specific sync keys) with your touch before the 2nd JB.

    Second Part,........For those attempting to use the program the first time, and havent JB'd before, you are probably not doing one of three things....first, make sure your IP address is correct (which you get in settings->wifi->properties->IP address), some routers change them from use to use, so what was correct before may not be this time (I am assuming youve read enough to know the default username and password are "root" and "alpine", respectively...both are case sensitive I assume...)
    Second, make sure your Wi-fi is on, this works over your wifi network. Third, you should have your touch plugged into the computer (although this might not be necessary from what Ive heard..) Just make sure your "ipod services" and "ituneshelper" are off via your task manager.

    Hope this helps, although I am by no means an authority on this subject...this stuff just worked for me, LOL.
    ...seems that most of the really knowledgable people on this board feel these types of questions are beneath them...I got very little help when I asked the same question....although in fairness, one or two did try.

    Good luck!
     
  10. hecks macrumors regular

    Joined:
    Oct 27, 2007
    #10
    Enough with the persecution complex already! When you've seen these questions asked another twenty gazillion times yourself, no doubt you'll start to feel the same way and be less quick to criticize. ;)

    What this board needs is some proper stickied threads. A FAQ at least would go a long way.
     
  11. igw macrumors member

    Joined:
    Oct 14, 2007
    #11
    How do you download the 1.1.1 firmware for the touch. I cannot find it. Also, if we update a jailbroken ipod touch, will the touch become a brick. What is the advice regarding firmware and such.

    Thanks
     
  12. mmfy macrumors regular

    Joined:
    Oct 23, 2007
    #12
    There are a few recent threads in this same forum e.g. "copy of firmware" etc...just do a search for "firmware " and you'll find them all in the iPod hacks forum.
     
  13. iBrendon macrumors newbie

    Joined:
    Oct 13, 2007
    #13
    This is the error I get someone please help me I would be very great full.


    The remote host actively refused the attempt to connect to it.
    1) Please verify that the destination host name or IP address is correct.
    2) Verify that the connection port number is correct (under Site Settings | Type tab).
    3) The remote server may be temporarily or permanently inaccessible (try again later).
    4) Verify that you have chosen the right protocol (SSH2, SSL, FTP, etc.) and have setup all required options for that protocol.

    I'm using cuteFTP Unregistered and I just got it today, a 16GB iPod Touch and I jailbroke it 3-4 days ago. Help please. =)
     
  14. madmaxmedia macrumors 68030

    Joined:
    Dec 17, 2003
    Location:
    Los Angeles, CA
    #14
    Make sure you've installed SSH as well, as not all JB methods automatically do that. For example I used jailbreakme.com, and I don't think it installs it.

    You can find it in Installer.app, I think it's called 'OpenSSH'.
     

Share This Page