Problem with Contacts in iMessage

Discussion in 'iOS 5 and earlier' started by gblais, Oct 12, 2011.

  1. gblais macrumors newbie

    Joined:
    Oct 12, 2011
    #1
    Hey Guys,

    Desperate (and recent) iPhone convert here. Just came off the blackberry and hoped I wouldn't have to deal with any crap...lo and behold here I am.

    Now that iMessage is out I'm wanting to use it preferentially, but when I start a conversation with someone via Contacts or by keying in their name in Messages, it stores the conversation under their number i.e., +1 (519) 555-4444 instead of by name i.e., John Doe. I've tried deleting all conversations, deleting the contact and re-adding them and still nothing. It shows me the number instead of the person. When I have a text conversation with someone, I don't have this problem.

    Any ideas to help me out? The net is giving me nothing...
     
  2. 8CoreWhore macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D
    #2
    I'm having a problem with iMessage, too. Give it a day, see how things shake out. A friend is trying to message me but iMessage is not an option. :(
     
  3. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #3
    Is that number in your address book under the person's name exactly as the number appears?
     
  4. gblais thread starter macrumors newbie

    Joined:
    Oct 12, 2011
    #4
    precisely... I've tried with multiple people.

    I found some indication that this was a bug in the beta version 1...doesn't seem like this is a common problem though.
     
  5. mrockm01 macrumors regular

    mrockm01

    Joined:
    Oct 25, 2007
    Location:
    NC
    #5
    I have never had that issue, but I would try changing the international code format. I am not sure why it would be the case but it couldn't hurt to play around with the "1" and "+1"
     
  6. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #6
    When in doubt, reboot & reinstall & set up as new.
     

Share This Page