Problem with control+<key> in Terminal.app

Discussion in 'macOS' started by GoKyu, Oct 4, 2010.

  1. GoKyu macrumors 65816

    GoKyu

    Joined:
    Feb 15, 2007
    Location:
    New Orleans
    #1
    Hi all, I did a full reinstall of Snow Leopard a few days ago (Not archive+install...I wiped everything clean), and now for some reason, the control keys in Terminal.app are acting screwy - I've never had an issue with this before, and I've only reinstalled the OS maybe 2 times in the last 3 years.

    The main issue appears when I use nano - anytime I want to do a control-X to save, it tabs forward 6 spaces. If I want to control-G for help, I get this symbol: ©

    The command key works fine, in that I can still copy and paste, but I need my control key to work as well. All the settings are default, terminal type is set to xterm-color.

    My main keyboard is a Bluetooth wireless Logitech, but I also tried the regular wired Apple keyboard, and it does the same thing.

    Are there any files I might need to check? If I need to edit a file, I *can* use vi without any issues, I just hate vi :)

    Thanks for any suggestions!
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Check your preferences for Terminal. Something related to keyboard settings may be awry - for example, you have Control set to be a modifier for typing special characters, when it shouldn't be.
     
  3. Hal Itosis macrumors 6502a

    Hal Itosis

    Joined:
    Feb 20, 2010
    #3
    Is it only in Terminal/nano where that happens (or did you just now post © in your browser by typing control-g?) Because that's exactly what option-g is supposed to do. So... the control key may be getting remapped somewhere. Check in System Prefs->Keyboard->Keyboard Shortcuts maybe.
     
  4. GoKyu thread starter macrumors 65816

    GoKyu

    Joined:
    Feb 15, 2007
    Location:
    New Orleans
    #4
    Hal: I didn't consider that, but turns out, you're right - I *can* hit control-G and get © anyway.

    Looks like I just found the issue...my program Double Command did have an option set (that I somehow missed) switching my Control and Option keys.

    Thanks for the tip :)

    Now, to avoid having to use this program, all I'm trying to do is reverse my command and option keys (It's a windows keyboard, and I want the command key to be the one closer to the spacebar. Is there a way to do this in OS X?

    Basically I want:

    Windows key = option
    ALT key = command

    Which is how the Double Command program has it, but is there an easier way to do this?

    Thanks again!
     

Share This Page