Problem with Cydia - Cannot Locate Package & Sources are empty

Discussion in 'Jailbreaks and iOS Hacks' started by jtang, Feb 17, 2011.

  1. jtang macrumors newbie

    Mar 10, 2009
    I know this issue's been covered ad nauseum but please bear with me. Have been researching this problem for the better part of 2 hours and still can't find a solution.

    This morning I tried to download an app of Cydia and I got a Note: Cannot Locate Package error. I did some research and found out it was probably because an update was corrupted or something, which leaves the Manage > Sources list blank. I tried Refreshing from the Changes tab, but the wheel just spins and nothing happens. Cydia is neutered, apparently.

    80% of the solutions I've seen involves SSHing into the phone and deleting some files, after which Cydia should restart. Problem is, I never installed OpenSSH or iFile before Cydia crapped the bed so I have no way of accessing the files.

    I've looked up a way to reinstall Cydia or even OpenSSH without Cydia but all I get is some dated instructions for the 3GS to install redsn0w and then a third party OpenSSH package - honestly I'm not comfortable with that. Not to mention redsn0w isn't even available to download from their website.

    So yeah, I'm reaching the end of my rope here. Anyone have any insight? Is re-jailbreaking a viable alternative?

    Apologize if this is a noob question, I picked this up about a week ago so I really don't know much about the intricacies of the iPhone.

    I'm running 4.2.6 on a Verizon iPhone 4.

    Thanks guys.
  2. dudeabiding macrumors 6502


    Aug 24, 2009
    Could you re-jailbreak w/GreenPoison? That should put Cydia (eventually) back on your phone. Anyone else? I've got AT&T but that's what I would do. Short of a full restore/re-jailbreak.
  3. eastercat macrumors 68040


    Mar 3, 2008
    iPhone explorer gives you root access. There are other programs as well, but that's what I use.

Share This Page