Problem with digital sound output

Discussion in 'MacBook' started by ogandojose, Feb 21, 2010.

  1. ogandojose macrumors newbie

    Mar 14, 2008
    Hello. I have a first-gen white macbook, you know, the core duo ones.

    The thing is that my audio port is stuck thinking it has connected a digital output and the red led is glowing all the time and I can't hear anything from speakers.

    I've tried connecting and disconnecting several times a plug, also tried to insert different objects as mentioned in other threads to disable the microswitch, but I can't.

    Is there a software fix for that? Can I disable the digital sound output so I can use my speakers?

    I know the speakers work cause I can hear the chime everytime I turn it on.

    Thanks a lot
  2. ogandojose thread starter macrumors newbie

    Mar 14, 2008
    Bump.... anyone?

    Sorry to bump but im desperate
  3. GfulDedFan macrumors 65816


    Oct 17, 2007
    There isn't a software solution that I know of and since this seems to be a hardware issue, it's impossible to help you out over the internet. You're trying everything that I've read to resolve your issue. The one that sticks out most in my mind is trying with a toothpick. I guess keep trying or bite the bullet and take your MacBook to an Apple Store or authorized repair place.

    Sorry and Good Luck.
  4. Mars478 macrumors 6502a


    Mar 6, 2008
    NYC, NY
    Mine has this problem. I'm sure a blast of compressed air will remedy it, but in the time being I just plug the phones in and out a bunch of times and it will fix itself. Other times I use a paperclip.

Share This Page