Problem with disk space after uninstalling BootCamp

Discussion in 'Mac Basics and Help' started by BigD84772, May 14, 2007.

  1. BigD84772 macrumors newbie

    BigD84772

    Joined:
    Dec 20, 2006
    #1
    I have a Macbook Pro with a 160 GB hard drive (disk utility reads 148.7 GB). Using bootcamp I installed XP on a 32 GB partition. After several problems with trying to get XP to run properly (driver issues) I finally gave up and deleted the partition, again using bootcamp. The problem is that the 32 GB partition seems to have either disappeared or become inaccessible.

    Here is what Disk Utility tells me:

    Capacity : 148.7 GB (159,697,911,808 Bytes)
    Available : 46.1 GB (49,514,029,056 Bytes)
    Used : 70.9 GB (76,113,764,352 Bytes)

    So, Available space + Used space = 117 GB, which is roughly 32 GB shy of the Capacity. Where did this space go?

    The first thing that I tried was the "verify disk" option in Disk Utility. Here's the report on that:

    Verifying volume “Macintosh HD”
    Checking HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Checking multi-linked files.
    Checking Catalog hierarchy.
    Checking Extended Attributes file.
    Checking volume bitmap.
    Checking volume information.
    Volume Header needs minor repair
    The volume Macintosh HD needs to be repaired.

    Error: The underlying task reported failure on exit

    1 HFS volume checked
    Volume needs repair

    Ok, no big deal, right?......except for the fact that the "repair disk" option is grayed out! :confused:

    Next, I started looking around the forums here and found that people have had success using Drive Genius to repair their hard disks. I downloaded Drive Genius and here's what it is reporting:

    Display Name: Macintosh HD
    BSD Name: disk0s2
    Drive Title: ST9160821AS Media
    Whole: No
    Leaf: Yes
    Writable: Yes
    Mounted: Yes
    BSD Major: 14
    BSD Minor: 2
    Preferred Block Size: 4,096 bytes
    Size: 148.73 GB (159,697,911,808 bytes)
    Used: 102.62 GB (110,183,989,248 bytes), 69.00%
    Available: 46.11 GB (49,513,922,560 bytes), 31.00%
    Removable: No
    Ejectable: No
    Content Hint: Apple_HFS
    Content: Apple_HFS
    S.M.A.R.T. Status: Verified


    So here, the 32 GB partition that I deleted is showing up as "used" space. My next problem is that Drive Genius will not let me perform any tasks on my hard drive other that to "repair permissions." All other utilities in Drive Genius, when I attempt to use them, give me the same error message:

    Device Error

    Unmount failed for device 'disk0s2' with 'Device is busy (The disk may be in use by an application.)' (0xF8DA0002).


    Even after restarting and making sure no apps are running I still get the same error messages. :( Can anyone help me fix this and reclaim my 32 GB?? Thanks in advance for the help. :apple:
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Well starting at the beginning, you can't repair the drive you boot from. This means that you'll either have to boot from the OSX discs and use that version of Disk Utility, or you'll have to run fsck from Single User Mode.
     
  3. libbyh macrumors newbie

    Joined:
    May 23, 2007
    #3
    same problem

    I've had the same problem (albeit with a different partition size), and I tried repairing the disk by booting from my install disk and using Disk Utility. It repaired fine, but I'm still missing all the space from the partition. The partition doesn't show up in any of Disk Utilities views either.

    Capacity : 148.7 GB (159,697,911,808 Bytes)
    Available : 30.8 GB (33,088,823,296 Bytes)
    Used : 97.2 GB (104,350,130,176 Bytes)

    How can I get my 20GB back? Boot Camp doesn't even see them; it shows my HD as 128GB with 30.8GB free.
     
  4. NoOneButMe macrumors regular

    Joined:
    Dec 10, 2006
    #4
    You'll need to expand the partition again to regain the space - iPartition or VolumeWorks should be able to do this.

    Or you could use diskutil via command line. After replacing disk1s2 with the right label for your hard drive - look it up in Disk Utility - Command should be:

    diskutil resizeVolume disk1s2 160G

    This should work, diskutil modifies the end point of a partition, not the starting point. You might need to adjust the end value to 148.7G.
     
  5. libbyh macrumors newbie

    Joined:
    May 23, 2007
    #5
    diskutil solved it!

    Thanks, NoOneButMe!

    diskutil worked, and now I have all my space back.

    The first time I tried, I used

    diskutil resizeVolume disk0s2 147.8GB

    and got this error: "Resizing encountered error Invalid argument (22) on disk disk0s2 Mac HD"

    Googling for that returns no useful information, unless you speak Italian. I read my command again and realized I'd used "147.8GB" instead of "147.8G" Just a reminder to be careful when entering commands.

    diskutil resizeVolume disk0s2 147.8G

    worked like a charm. Thanks again!
     

Share This Page