Problem with Epson printer working with iMac

Discussion in 'Mac Basics and Help' started by markthedoc, Jul 19, 2007.

  1. markthedoc macrumors newbie

    Joined:
    Apr 24, 2007
    Location:
    Northwest England. UK
    #1
    Hi
    I bought an Intel iMac machine a few months ago but I'm having a few problems getting my Epson CX6400 printer working via USB.
    When I connect the USB lead into the slot on my keyboard the printer works fine. However when I connect the USB lead directly into my Mac it doesn't work and I get a 'communication error'. It's not a faulty socket on my Mac because the keyboard works on all 3 sockets.
    Anyone else had this problem or has anyone got any ideas on how to solve this?

    Cheers.

    Mark
     
  2. Mac21ND macrumors 6502a

    Mac21ND

    Joined:
    Jun 6, 2007
    #2
    Interesting...

    I'm guessing it has something to do with USB 1 versus USB 2 and/or powered USB ports. The keyboard isn't powered USB and I think it's USB 1. The main USB ports in your iMac are powered and USB 2.

    Have you tried using a new, USB 2 cable with your printer? USB 2 should be backwards compatable with USB 1. My hunch is perhaps your USB cable is old USB 1 and doesn't like the USB 2 powered connection.

    Anyways, just an idea. Hope it helps.
     
  3. markthedoc thread starter macrumors newbie

    Joined:
    Apr 24, 2007
    Location:
    Northwest England. UK
    #3
    Hi Mac21ND thanks for the reply.
    I haven't tried another USB lead because the lead I'm using is a 10m lead because my printers over the other side of the room. I'll try a USB2 lead though out of interest. I'm guessing the lead is USB1. I'll try and locate a 10m USB 2 cable I think!
    Thanks for your help.
     

Share This Page