Problem with External Hard drive & Time Machine

Discussion in 'Mac Accessories' started by phoenix09, Jan 18, 2015.

  1. phoenix09 macrumors newbie

    Joined:
    Jan 18, 2015
    #1
    Hello all, I'm looking for a solution to a problem with my external hard drive.

    First of all I'm running 10.10.1 on a Macbook Pro, and the external hard drive in question is a 1 TB Cavalry connected via USB.

    I've been using it for some time, at least a year, with the Time Machine to store back ups for my laptop, it's been working great, no problems whatsoever. Today however I went to back up and despite the drive being connected and on, Time Machine wasn't recognizing it being connected, and it didn't show up in the finder or desktop. I opened up Disk Utility and it did show up there, I told it to check disk, it said it had errors and needed to be repaired. When I tried to repair it I would simply get an error message saying that DU can't repair the problem. I figured I'd cut my loss and reformat it and back up again, no big deal unless my laptop blows up during the process. Using DU, I go to erase the drive and it just says that it can't unmount the disk, regardless of anything I try. It doesn't appear that the disk is mounted in the first place since it won't show up in finder or desktop. I've tried various combinations of restarting the computer, with Time Machine on, and then off, with the hard drive connected, with it not and nothing has worked. I've also tried using the Terminal to force the drive to unmount thinking then I could use DU to erase it, but even Terminal says it can't unmount the disk.

    Does anyone have an idea for a next step? Thanks in advance!
     
  2. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #2
    Last time this happened to me, oh 4-5 years ago, it was just a drive that went bad.
     

Share This Page