Problem with external hard drive

Discussion in 'Mac Basics and Help' started by mojojojojo, Dec 9, 2013.

  1. mojojojojo macrumors newbie

    Joined:
    Dec 9, 2013
    #1
    Hello!

    I know there are alot threads about external drive problems but I need suggestions in my specific problem.

    So.. I'm using a 15" MBP from mid 2010 with i7 and a Western Digital 2 TB formated for mac, I don't know the exact model but I can find out if necessary, about 2 years old.

    And I can't access the drive anymore. It doesn't show up in Finder. I can find it in Disk Utility but its name is "disk1s" which isn't what I named it. The "Control disk" and "Repair disk" buttons are grayed out so I cant do that.
    I have rebooted both the computer and hard drive, bought a new USB cable, tried all my ports and it still doesn't work.

    My friend can read the drive tho, on his Acer from 2010. He downloaded some software and it works.

    What do you suggest?
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    Have you tried (paid software) Disk Warrior?

    Or bring it to Apple Store and have it checked out?
     
  3. mojojojojo thread starter macrumors newbie

    Joined:
    Dec 9, 2013
    #3
    Thank you for your answer.

    Yes, I have Disk Warrior but I haven't used it yet. I don't know if Disk Warrior is the right tool since it seems like the data is there but I just can't connect. So is Disk Warrior the right thing for me or is there any other way?
     
  4. justinmartin macrumors newbie

    Joined:
    Oct 22, 2013
    Location:
    Toronto
    #4
    Could this be caused by the issues that WD has having with their drive software? I know that they issues a statement in regards to possibly losing data - take a look at their site as your drive / software may need an update.
     
  5. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #5
    Sounds like you could be using the WD Turbo software. You can remove it with a risk of losing data though. If you don't have the WD drivers installed or you need the uninstaller, visit their site for up to date information.
     
  6. mojojojojo thread starter macrumors newbie

    Joined:
    Dec 9, 2013
    #6
    There is no software for Mac (except WD Quick Formatter) on their site, and I haven't installed any software, but thanks for the tip.

    I'll ask at their support and see what they think!
     
  7. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #7
    If you initially used the quick formatter, or left the drive as is when you bought it, you may be suffering the same issues as many here. My two 2TB drives are fine but I formatted them HTFS when I put them into new enclosures
     
  8. VANJEANNE macrumors newbie

    Joined:
    Dec 24, 2013
    #8
    Wd5000h1u-00 problems

    2 weeks ago my ext hard drive could work. I may have unplugged my mac which was still connected to the ext hard drive. Now it isnt working. It doesnt light up, no sounds at all, unplugged and plugged it several time and nothing. It's not vibrating at all, its cold and no activity. What do i do to recover the data. I need the date inside. Thanks
     
  9. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #9
    The WD drive is about 2 years old, is this correct?

    If it's out-of-warranty, my suggestion would be to try this:

    Open the case and take the drive itself OUT of the case.

    Assuming that the "bare drive" has a standard "SATA" type connector (see note below), I would suggest you get a USB3/SATA docking station. To see what these are, go to amazon.com and enter "usb sata dock" in the search area, and you will get many choices. These are very affordable (typically, less than $25), and will prove to be a very useful device in your Mac future.

    One that would work (again, assuming the drive has a SATA connector) is this:
    http://plugable.com/products/USB3-SATA-U3

    Once you have the dock, put the drive inside, and connect to the Mac, and turn it on.

    Then you should hear/see
    1. The drive should "spin up" in the dock
    2. The drive should mount on the desktop

    If the drive does not spin up, sounds like a hardware failure.

    If the drive spins up, but doesn't mount on the desktop, could be corrupted directory that prevents it from mounting. If this is the case, and there are no hardware problems, the data on the drive may STILL BE RECOVERABLE.

    If you do the above, and can get this far, report back and we'll take it from there.

    Note:
    WD is notorious for NOT using a standard SATA type connector for some of their pre-packaged external drives. You're going to have to open the case and examine the drive to know whether this is true for your situation or not.
     

Share This Page