Problem with External iSight and no audio

Discussion in 'Mac Accessories' started by mlevack, Oct 28, 2007.

  1. mlevack macrumors newbie

    Joined:
    Jun 29, 2007
    #1
    I purchased an original iSight after having problems with my USB cam. I just did a clean install of Leopard on my mac pro. The USB cam would get errors in iChat such as "Camera in use by another application, etc).

    I uninstalled the iChatUSBcam software, checked the Library/quicktime folder, etc.

    I hooked up the iSight and it seemed to work, then the video went a bit haywire. I thought it was just a glitch, but when I tried to video chat, the other user could not hear my voice. I checked the System pref sound input and it was on the iSight, but the meter was not responding properly.

    I thought it may be a hardware issue, so I tested the iSight on my mac mini (G4) - It worked perfectly.

    I have uninstalled iChat and reinstalled it from the Leopard disk. Still no go...

    After two days, I currently get a good video signal, but am not getting any audio when hooked up to any port on my mac pro, but it works perfectly on the mac mini, so I am still convinced that this is a some sort of driver of software conflict

    Any Advice?
     
  2. vadalus macrumors newbie

    Joined:
    Jan 11, 2008
    #2
    Problem with External iSight and no audio

    I have *exactly* the same issue. Thought it might be the iSight playing up but i do not have another machine to test it on.

    Did you have any luck addressing the issue?

    vadalus
     
  3. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #3
    iSight playing up on more than 2 cameras? Seems everyone with a iSight, who's running Leopard are having the same issue, you're not alone... here's a thread on the apple's forums...
     
  4. vadalus macrumors newbie

    Joined:
    Jan 11, 2008
    #4
    Problem with External iSight and no audio

    Looks as though the issue was addressed by updating to the later version of he firmware, anyone know how to do this in leopard..? the updater is not compatible with the latest OS (joy)
     
  5. vadalus macrumors newbie

    Joined:
    Jan 11, 2008
    #5
    Problem with External iSight and no audio FIXED

    I have just upgraded from 1.0.2 to 1.0.3 "using" leopard, i did it by running \System\Library\CoreServices\iSight Updaters\iSight Updater

    Running this, it explicitly stated my iSight needed updated and whether to proceed and update. Which I then did and ENTIRELY FIXED THE ISSUE I WAS HAVING WITH SOUND.

    Hope this helps.
     
  6. mamasboy macrumors member

    Joined:
    Jan 11, 2008
    #6
    Vadalus - YOU ARE THE BEST!

    I have Leopard, scored a new external i-sight off ebay and boom - no sound - but great video. However, I ran the exact solution detailed by vadalus - and: PRESTO - AUDIO WORKS GREAT!

    THANK YOU,
    mamasboy
     
  7. rrwoodward macrumors newbie

    Joined:
    Jan 25, 2008
    #7
    DUDE!!!, are most certainly the BEST!!! Thanks a TON!!!

    As simple as it turned out to be, it took me hours to find YOUR fix, and it worked perfectly. Thanks

     
  8. rg-easton macrumors newbie

    Joined:
    Apr 30, 2008
    #8
    Vadalus has the answer. Works great!!!

    :)
     
  9. planetdom macrumors newbie

    Joined:
    May 30, 2010
    #9
    I could not get my audio to work then i came across this post and now the isight camera audio works

    i was able to update my FireWire iSight to 1.0.3 under Leopard and this seems to have fixed the microphone problem. The iSight had 1.0.2 on it. We have this problem on at least 3 cameras.

    I didn't have a 10.3.x system around, but was able to open the iSightUpdater103.pkg file by right clicking and selecting "Show Package Contents". Inside is a file called Archive.pax.gz. Double clicking created ~/Downloads/Applications/Utilities/iSight Updater 1.0.3/iSight Updater 1.0.3.app. I ran this and it updated the iSight with no hitches.

    Hope this helps

    Dominic
     
  10. dscott77 Guest

    #10
    External iSight and Snow Leopard - It Works!!!

    Thanks to "Dominic" (see previous post), I just now was able to download the software update for my old, external iSight and, based on his instructions, successfully installed the upgrade, even though I'm running OS X 10.6.7 on a Mac Pro. Most every other Google search suggests more complicated workarounds using pre-Leopard Macs (that I don't have). My iSight had been at version 1.0 and now it is 1.0.3. Previously the iSight produced a greenish picture and NO audio. Not only do I now have audio (with moving meters) but the greenish cast is mostly gone. Of course, there may be a reason why Apple has chosen not to make this upgrade readily available to us Snow Leoparders and I may be rewarded with a kernel panic but, so far, so good. Dominic, you da man!
     

Share This Page