Problem with Firefox and Spaces...

Discussion in 'Mac Basics and Help' started by .:r32, Feb 6, 2008.

  1. .:r32 macrumors newbie

    Feb 4, 2008
    Hi everyone,

    I'm looking for some help again. I'm using Spaces on my Mac (2x2 grid) and I have this problem with Firefox. So I have Firefox set to open in Space 1, and iTunes in Space 3. So, if I Command+Tab to Firefox from iTunes or if I just click the Firefox icon in my dock to switch to it, it switches to the appropriate space, but the Firefox window does not take "focus" (i.e. I have to click on the window again AFTER having already switched to the program in order to start doing anything. If I'm using Safari (or any other program really) and I switch to Safari from iTunes, the Safari window will take focus, but for some reason Firefox does not. Does anyone have any idea on how I can fix this? Any help is appreciated, and I hope I articulated my problem well (if not please ask a clarifying question and I can try and explain better).
  2. match311 macrumors member

    Jun 16, 2007
    I just tried it out and the firefox window does NOT focus either. I don't know if I can help you fix it but atleast you know you're not the only one.
  3. overanalyzer macrumors 6502a

    Sep 7, 2007
    Boston, MA USA
    I've noticed this problem too, though I haven't come up with a solution. I've gotten into the habit of hitting command-~ when I switch to Firefox via command-tab, which will give the browser window focus. At first it was annoying, but now I do it so automatically I don't think about it.
  4. clevin macrumors G3


    Aug 6, 2006
    I heard this is a problem that happens to some apps other than firefox/thunderbird as well, so maybe a leopard bug.

    Edit: maybe you should try out firefox 3 beta 2 (beta 3 will be out in a few days) says it was fixed at mozilla end in firefox 3 beta1
  5. strepsata macrumors newbie

    Dec 3, 2009
    similar firefox spaces issue

    Not sure what you mean when you say focus, but I have a similar issue. When I click out of a Firefox window and then work in an application in another space, I can't get my Firefox windows to show up. This is a recent issue since updating to Firefox 3.6.

    The windows tab shows all the windows I have opened, but I can't see them. When I quit Firefox, the alert message asking if I was to save my tabs appears way up in the lefthand corner, with half of it invisible off the screen.

    If I turn off spaces I don't have this problem. But I like using spaces. This is annoying.

    I'm going to try assigning Firefox to Space #1 and stead of space #2(I use 3 x 2 layout), and see if that helps. I'm thinking Firefox is aligning it's windows somewhere in between spaces????
  6. Gregg2 macrumors 603

    May 22, 2008
    Milwaukee, WI
    Is Firefox the only application running in that Space when this happens?

    If so, are you sure it was the active application (instead of Finder) when you left that Space last time?

Share This Page