Problem with GTA4 on bootcamp win7 64bit

Discussion in 'iMac' started by Aarnub, May 12, 2011.

  1. Aarnub macrumors newbie

    Apr 26, 2011
    Amsterdam, Netherlands
    Hey guys,

    I received my new iMac yesterday: 3,4Ghz i7, 4GB ram, 6970M 2GB. I installed Windows 7 Home Premium (64-bit) yesterday with bootcamp, which is working fine. I installed some windows games like Dragon Age 2, Crysis 2, Assassins Creed Brotherhood and GTA4 which all run fine on the highest settings, except for GTA4.

    The game starts up fine and runs without lag, untill I start driving a car and start making turns. With turns I mean driving left or right. When I make a turn the game freezes for a second and then continues, this happens every time I make a turn.

    The auto graphics configuration in-game sets the graphics to high on the native resolution. So I figured well let's try setting the graphics a bit lower, but it didn't make a difference, so I put them on the lowest possible. Still the same problem, lag when I drive left or right.

    I looked up drivers for the AMD Radeon 6970M and downloaded and installed the Catalyst control center ( which installed the latest driver for the 6970M. But still no difference.

    Has anyone ever heard about this problem? I can't seem to find it anywhere. Any suggestions how I can fix this, could it be a ram problem? (though I doubt that).

    Let me know what you think
  2. Georgio macrumors 6502


    Apr 30, 2008
    Essex, UK
    As this seems to be happening when you're making an input, i.e. turning, the question needs to be asked what method of input are you using to turn?
    If you're using a USB wheel are you sure you have the right drivers installed, have you calibrated it in Win7 etc.
    If you're using a wheel/pad/joystick, try setting up the keyboard as an input and see if the problem persists.
    If you're already using the keyboard then try using a different keyboard.
    Also maybe try reinstalling DirectX to see if the Direct input has somehow become corrupt.
    Above all try different options to try and isolate why this would only happen in this game and only when you input.
  3. Aarnub thread starter macrumors newbie

    Apr 26, 2011
    Amsterdam, Netherlands
    Thanks for the reply,

    I am playing with keyboard and mouse only. I just tried another keyboard (Logitech Mediakeyboard 600) but it doesn't seem to make a difference, i've also tried connecting it to several USB ports but still the same problem.

    Any other suggestions where the problem may lie?
  4. MacAndMic macrumors 6502

    Jun 4, 2009
    Do a google search and you will see you are not alone regardless of the computer being used.

    Many point to graphic settings but you have already proven that, others simply blame a bad latest patch.

    Frustrating I am sure.....good luck!
  5. Wormald macrumors regular

    Jun 10, 2011
    I had the same problem on my shiny new i7 Macbook Pro, and found your thread looking for a solution.

    I can report that I have found one!

    Sign up for a full-on Windows Live account from within the game. This will then initiate an update of the Windows Live system from within the game.

    After this update, go to the Windows Live interface in the game again, and associate the account with the Games For Windows thing.

    After doing this, poke around in the Live interface a bit more, and it should inform you that there's an update available for the game - get it downloaded and installed, and bob's your mother's brother...

    The turning lag issue should hopefully go away. It has for me.

    There's also the option to activate the downloadable content in the update, and to not have to play the game with Rockstar Social Club. But you've got to sign up to RSSC to begin with to download the patch so what's the bloody point... oh how I hate convoluted sign-up systems - and windows in general...

    Let me know if you have any luck with this anyways!

Share This Page