problem with hd video in qt

Discussion in 'Mac Basics and Help' started by rmbpuser, Sep 1, 2012.

  1. rmbpuser, Sep 1, 2012
    Last edited: Sep 2, 2012

    rmbpuser macrumors 6502

    Joined:
    Sep 1, 2012
    #1
    I just got my basic rMBP model yesterday and am really happy with it so far except that when I try to play a 1080i mpeg2.ts video Quicktime freezes for half a minute before starting the video.I just can't think of a reason why this happens, my laptop surely should be able to handle it without a problem.I thought it would just load it like a lighting with the ssd and overall configuration to be honest.
    Any idea why this is happening?
     
  2. rmbpuser, Sep 2, 2012
    Last edited: Sep 2, 2012

    rmbpuser thread starter macrumors 6502

    Joined:
    Sep 1, 2012
    #2
    Finally I found "the problem" after trying out 3 other programs and several add-ons, and a lot of searching in the corners of Google where the sun doesn't shine, I learned that QuicktimeX takes time to parse multiplexed files which explains why I can scroll the video while it's on pause with no problem but when I press play initially it takes around 30 sec to; as I understand it; sync the different audio and video formats,something that happens instantaneously in programs like VLC for example(I didn't stick with it because despite that QT takes so long to load it still is so very better).That also means larger videos will take longer to load and mine is 5GB, oh well I guess I should be happy that my Quicktime comes equipped with "mpeg2 playback" and can play them at all.

    Pfft now I feel bad for installing and deleting so many programs, I know they always leave traces behind and slow your system over time and I'm really OCD about my new toy right now.



    welp that was a long post I hope it might help someone else who wonders why his videos load that bad on his new laptop(as if), cheers.
     

Share This Page