Problem with heart rate during workout

MoodyM

macrumors 6502a
Original poster
Aug 14, 2008
776
24
My Watch has been been fine for weeks, both during workouts and in normal use.

However on Wednesday I went for my usual lunchtime run and set it to Outdoor Run (as always) but when we were finished I noticed it hadn't recorded my heart rate at all.

I then played soccer at night and as usual I set it to Other workout. I checked to make sure it picked up my HR at the start, but I noticed at various points (i.e. every few minutes) that the measurement was
"greyed out" and the Watch said "measuring" for ages.

And yes, the Watch was on tight (tightest hole of Sport band, which is bordering on too tight for me, I usually wear it day-to-day on 2nd tightest hole).

And no, I don't have tattoos on my wrist. Plus, it has worked fine under the same routine for weeks.

Also, on the day in question, the heart rate measurements outwith the Workouts seem to be fine.
 

rpramanik

macrumors regular
Aug 8, 2008
117
9
San Francisco, USA
My Watch has been been fine for weeks, both during workouts and in normal use.

However on Wednesday I went for my usual lunchtime run and set it to Outdoor Run (as always) but when we were finished I noticed it hadn't recorded my heart rate at all.

I then played soccer at night and as usual I set it to Other workout. I checked to make sure it picked up my HR at the start, but I noticed at various points (i.e. every few minutes) that the measurement was
"greyed out" and the Watch said "measuring" for ages.

And yes, the Watch was on tight (tightest hole of Sport band, which is bordering on too tight for me, I usually wear it day-to-day on 2nd tightest hole).

And no, I don't have tattoos on my wrist. Plus, it has worked fine under the same routine for weeks.

Also, on the day in question, the heart rate measurements outwith the Workouts seem to be fine.
I read somewhere too tight is also bad.
 

Julien

macrumors G4
Jun 30, 2007
11,270
4,222
Atlanta
My Watch has been been fine for weeks, both during workouts and in normal use.

However on Wednesday I went for my usual lunchtime run and set it to Outdoor Run (as always) but when we were finished I noticed it hadn't recorded my heart rate at all.

I then played soccer at night and as usual I set it to Other workout. I checked to make sure it picked up my HR at the start, but I noticed at various points (i.e. every few minutes) that the measurement was
"greyed out" and the Watch said "measuring" for ages.

And yes, the Watch was on tight (tightest hole of Sport band, which is bordering on too tight for me, I usually wear it day-to-day on 2nd tightest hole).

And no, I don't have tattoos on my wrist. Plus, it has worked fine under the same routine for weeks.

Also, on the day in question, the heart rate measurements outwith the Workouts seem to be fine.
Have you tried a restart? Could jut be an anomaly that will clear up after a restart.
 

exxxviii

macrumors 65816
May 20, 2015
1,423
555
No, I don't even know how to.
Open the watch app on the phone, scroll down to the workout app, and tap it. The workout app has two options. The second option is the Power Saving Mode that disables HR reading. That should be off, as shown in the screen shot below.
 

MoodyM

macrumors 6502a
Original poster
Aug 14, 2008
776
24
Ahh ok, yes that setting is off and always has been
 

MoodyM

macrumors 6502a
Original poster
Aug 14, 2008
776
24
I went for a walk tonight, set it to Outdoor Walk. The difference tonight was I'm using a Milanese Loop and not a Sports Band. The Loop is on pretty tight, enough so it definitely doesn't move during a walk.

I set the display of the Workout app to Heart Rate, and off I went.

I kept checking it to see if it was doing the greyed out/"Measuring" thing it was doing before, and for the first 10 minutes all seemed fine. Then, one of the times I glanced at it, sure enough it was greyed out and saying "Measuring".

The weird thing is my heart rate had been around 80-95 the whole walk. As soon as it came back from the "Measuring" episode, it was reporting 114bpm, despite the fact I hadn't went up a hill or sped up! After around 1 minute, it correctly starting reporting mid 80s again, and was fine for rest of walk!

Any idea what's going on?

Screenshot attached:

 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.