problem with installing new mojave

Discussion in 'macOS Mojave (10.14)' started by armin.firstsource, May 26, 2019.

  1. armin.firstsource macrumors newbie

    Joined:
    May 26, 2019
    #1
    Hello

    i have a macbook pro 2018
    there was a mojave OS on it and i didnt had its password. for previous user
    1- tried to boot with usb installation disk of mojave but i received message about noy allowing to boot form external disk
    2- then i boot up device with command R
    3- i did format to the internal drive to be able to install from usb install disk
    4- after rebooting i still couldnt pick my usb as a boot disk and mac keeps asking to boot from internet recovery mode
    5- i had no choice. i picked internet let it to finish downloading from internet but after that i got recovery mode screen and still same problem that im not allowed to boot from disk . but there was no disk

    i tried reset smc . no change
    cant select usb at boot . when i choose usb it will jump to wireless again . and after downloading from wifi still same error about not allowing to install from external.

    it becomes to an infinit loop

    im stock in this between with no option
    any suggestion or help ?

    thank you
     
  2. Stephen.R macrumors 65816

    Stephen.R

    Joined:
    Nov 2, 2018
    Location:
    Thailand
    #2
    This sounds extremely suspicious.

    Where did you get the laptop?
     
  3. armin.firstsource thread starter macrumors newbie

    Joined:
    May 26, 2019
    #3
    no its not suspicious
    laptop belongs to company that im working for
    I'm their new IT
    previous user of the laptop left and i didn't had passwords so i decided to format ssd and reinstall mac
    Previous IT also doesn't had password of the previous user
     
  4. Stephen.R macrumors 65816

    Stephen.R

    Joined:
    Nov 2, 2018
    Location:
    Thailand
    #4
    Still sounds suspicious to me.

    An it department that doesn’t create its own admin account on the machine? Even if what you say is true, needing to know a users password like that is pretty damn shifty.
     
  5. Lee_Bo macrumors regular

    Lee_Bo

    Joined:
    Mar 26, 2017
    Location:
    Greenville, SC
    #5
    This may be legit but does sound a little funny.

    Two things come to mind. Most companies have policies that dictate admin accounts will be set up on all computers just for this very issue.

    Second, wiping a Mac and reinstalling the OS from the internet is very simple to do, but there are a couple of "gotchas" that you have to avoid. Unfortunately since I do not know for sure if what you are saying is true, I don't feel comfortable posting that information here. But Google is your friend.

    And yes, I am one of those people that makes sure all of our companies machines have local admin accounts on them.
     
  6. CoastalOR macrumors 68020

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #6
    Since it is a 2018 MBP I think you are having problems getting past the T2 chip security settings.
    https://support.apple.com/en-us/HT208862
    https://support.apple.com/en-us/HT208330
     
  7. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #7
    I think what you may need to do is this:

    1. Boot to internet recovery. Open Disk Utility. Choose "show all devices" (upper left popup).

    2. Use Disk Utility to ERASE the internal drive.

    3. Do a completely clean re-install of the software.

    4. When you get to setup, create an account.

    5. Now reboot to the recovery partition.

    6. Open Startup Security (it will ask for a password). Can you now make changes in Startup Security?

    7. If you can, you want to select the option to allow booting from external drives.
    (I would also recommend that you select the "no security" option as well)

    Not sure if it will work, but worth a try.
     

Share This Page

6 May 26, 2019