problem with installing Windows 7 on Macbook Air 2010 via Bootcamp 4.0.1 (Lion)

Discussion in 'MacBook Air' started by s2dio, Dec 7, 2011.

  1. s2dio, Dec 7, 2011
    Last edited: Dec 8, 2011

    s2dio macrumors regular


    Oct 28, 2010
    Riga, Latvia
    Hello, dear Macrumors mates!

    I tried it a couple of times and searched the forum and the internet for information, but I guess this case has not been discussed much yet.

    I have a Macbook Air 2010, 13" ultimate. It came with Snow Leopard and I managed to install Windows 7 Professional 64bit from USB flash drive on it with only a little hassle.

    Recently, I did a clean install on Lion and I'm now trying to install the same Windows 7 on it via USB flash drive.

    The problem is that Lion has a different Bootcamp version (4.0.1) and the whole process has been slightly modified. I have read that "there hasn't been anything easier than installing Windows 7 on a Macbook Air 2011 with Bootcamp version 4.0.1 in Lion".
    Yeah, but could there be a problem that my Macbook Air is a 2010 version and it interacts with Bootcamp differently than Macbook Air 2011?

    Bootcamp ver. 4.0.1 is advertised that way that it doesn't even require rEFIt and does everything itself from start to end.

    I have a flash drive with Windows 7 on it, but the Bootcamp Assistant doesn't go further than the screen with disk partitioning. After I select the amount of space to dedicate for the Windows installation and press Install (in older Bootcamp version the button was called "Partition"), a message pops out, saying "Insert your Windows installer disc and wait for a few seconds for the disc to be recognized". And that's it, nothing happens.

    I have tried to create a partition manually, using Disk Utility. But it only gives an option of FAT, no NTFS. And when I boot the computer from the USB flash drive with Windows installation, it cannot install itself on this partition. And it's unable to reformat the partition.

    So I find myself in a situation where I can't install Windows 7 from a USB flash drive.

    Has anyone encountered a similar problem? What solutions should I try to apply?

    Thanks in advance.

Share This Page