Problem with IOstorageFamily.kext

Discussion in 'macOS' started by LuapStar, Apr 2, 2010.

  1. LuapStar macrumors newbie

    Mar 27, 2009

    The following message came up when trying to connect an external drive to the usb port:

    "System extension cannot be used

    The system extension /System/Library/Extension/IOstorageFamily.kext was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update."

    Earlier I installed Disk Warrior 4.2. After using it I restarted the system and when I wanted to use a usb-stick the message came on the screen and the device did not function.

    There was problems with the FW800 port as well.

    This thread did not help me that much..

    Would be very glad and grateful if someone could help me with this!

    - F
  2. BobMcFish macrumors newbie

    May 3, 2010
    South East England
    Don't get excited, this is not a fix

    Sorry you are having that problem. I have it too with numerous different external USB drives and have also had it with a USB scanner and a memory stick
    Normally what happens it that I get the error when I plug in a device. I unplug the device again and reboot. I get the spinning startup circle then a No Entry sign and it's Game Over for the OS. I re-install the OS from my OS DVD and I'm up and running again until the next time I get the error. It is always invoked by plugging in a USB device. I had another problem where my Mac would power on by itself as soon as I plugged the mains cable in. One time, after an IOstorageFamily.kext error, my MacPro would not allow me to install the OS again. I just got the spinning circle and it would not see the OS DVD. I took it in to Apple to get them to fix it. They installed a new Logic Board (£400 - ouch!) which solved the problem with the powering on by itself and the inability to re-install the OS but the IOstorageFamily.kext error reappears every now and again
    The last two times it has happened I have just rebooted straight away without unplugging the drive. Upon reboot, the drive is accessible and all is well. I am mystified by all of this. Once when I got the IOstorageFamily.kext error I ran Disk Utility and it showed me my external disk as being connected but not mounted
    I'm gutted because I no longer trust my MacPro or any of my external drives - I have 3. I can't get Apple to fix it because every time I take it in to the Apple Store Genius Bar they reinstall the OS and watch me plugging in USB devices randomly without so much as a sniff of a complaint from the OS
    I hope that you get a resolution for your problem. I'm not so sure I will
    Did you try replacing the IOstorageFamily.kext file as suggested in the thread you linked? You need to have a working backup of course!
    Best of luck
  3. henin macrumors newbie

    May 28, 2010


    Seems that an errant DiskWarrior icons file gets inserted in the IOstorageFamily.kext file.

    a) Go to the file in /System/Library/Extensions.
    b) Control-click it and select "Show Package Contents."
    c) Go to Contents/Resources.
    d) Delete the Preview.icns file.

    Problem solved!
  4. Bregalad macrumors 6502

    Jul 22, 2002
    Sometimes an old thread comes to the rescue. One of my FireWire drives stopped mounting when I tried to hot plug it. I opened the package above and discovered Preview.icns lurking in mine too. Thank you!!
  5. BobMcFish macrumors newbie

    May 3, 2010
    South East England
    You absolute life saver Henin


    Thank you so much for taking the time to help us with this.

    Firstly, your fix worked exactly as you said and indeed I had run Diskwarrior today. I found it on an old disk and wondered if it worked so I ran it. Didn't do anything with it, just ran it, then deleted it because it could not see all of my drives so I didn't trust it. Seems it left me with a little gift before it went

    Having come back to this thread I see that I have not been updating it with my findings. After taking my Mac to Apple and it not exhibiting the problem, I eventually discovered that it was an iTunes update which was trashing my OS. Having recovered my OS from a clone of it, I installed the software updates one by one until BINGO! An iTunes update was installing and then the dreaded error message came up "system extension cannot be used - IOstorageFamily.kext is FUBAR"

    I replaced it from a backup and all was OK

    This time round I got the error message when I put a CD in the drive. As soon as I pressed the Eject key to close the drive the error message came up and the CD spun up but did not mount. I rebooted expecting the dreaded spinning circle and ensuing Exclamation Mark but it came back up again but with the same error on inserting the CD

    That was when I found this post (forgot I had posted and had not seen Henin's response and thus had not thanked you for it Henin)
    So, thanks again. Brilliant !!!
  6. Phloem macrumors newbie


    Feb 13, 2008
    Possible Solution

    I know this is now an old thread, but I feel I should post here as it's the top item on Google search for this problem.

    I use IconBox for OSX Mavericks, so the problem is similar. I had changed the default drive icons for removable drives.

    I found repairing disk permissions solved the problem.

    Go to: Applications > Utilities > Disk Utility
    Then: Click repair disk permissions.

    I do not know why I had not thought of doing that sooner, I have had the problem for weeks :eek:

    Source :apple:

Share This Page