Problem with iTunes sync - wants me to Restore

Discussion in 'Jailbreaks and iOS Hacks' started by newrazr, Sep 10, 2010.

  1. newrazr macrumors member

    Joined:
    Aug 8, 2010
    #1
    I've got a JB iP4 and have been using wi-fi sync largely without issue. Today I did a sync via wi-fi sync and then added a few new podcasts. I exited out of iTunes10 and when I went back in, I got the following error message:

    <<iTunes cannot read the contents of the iPhone "Jack's iPhone". Go to the Summary tab in iPhone preferences and click Restore to restore this iPhone to factory settings.>>

    Any idea what's going on? This now happens every time the phone is connected, whether by USB or wifi Sync. The only tab that appears is the Summary tab and the only option it gives me is to restore. It still lists my software version, serial number, IMEI, phone #, etc. but the capacity is now listed as "n/a" and the Name is now listed as "iPhone"

    Obviously I'd prefer to avoid having to restore & rejailbreak so I welcome any other suggestions if you've got'em.
     
  2. newrazr thread starter macrumors member

    Joined:
    Aug 8, 2010
    #3
    Thanks for the suggestion. Tried that and uninstalled wifi sync via the uninstaller. rebooted the Mac but the problem still continues when connected via USB (wifi sync remains uninstalled).

    Any other ideas?

    I also connected the iphone to a "new" computer that it had never been connected to before and the same error message popped up so I'm wondering if there might be some sort of file in the phone that got corrupted. if anyone has any idea what that might be perhaps I could SSH into the phone and edit or remove the file??

    I can also see all the files via iPhone explorer if that makes a difference....
     
  3. MrThompsonR macrumors 6502

    MrThompsonR

    Joined:
    Dec 15, 2009
    #4
    Did you respring/ reboot after removing the app from your phone?
     
  4. newrazr thread starter macrumors member

    Joined:
    Aug 8, 2010
    #5
    Problem Solved!

    Ended up finding a fix via google (yeah, i know, i probably should have done that first....) but in the interest of saving others from the headaches, here's what I had to do:

    Using iPhone Explorer (or via SSH into the phone), I deleted “/private/var/mobile/Media/iTunes_Control/iTunes/iTunesDB” database file and then re-started iTunes. All was well.

    Kudos to Bosaka who posted the solution in the comments section here
     
  5. spiels123 macrumors newbie

    Joined:
    Jul 11, 2010
    #6
    I'm hoping this will solve my problem. Is this solution just for jailbroken phones? Mine is not. I'm using Vista. If anyone can help that would be great! An annoying problem.
     
  6. newrazr thread starter macrumors member

    Joined:
    Aug 8, 2010
    #7
    Yes -- it's for jailbroken phones. If yours isn't then I'm not sure how to fix the problem.
     
  7. spiels123 macrumors newbie

    Joined:
    Jul 11, 2010
    #8
    I used iPhone Explorer with my iPhone to delete all the necessary files & music and it worked fine. I guess that software works with iPhones which haven't been jailbroken which is nice! All back to normal...
     

Share This Page