Problem with jailbreaking/unlocking: 3gs

Discussion in 'iPhone Tips, Help and Troubleshooting' started by stephsays, Jul 18, 2011.

  1. stephsays macrumors newbie

    Joined:
    Jul 18, 2011
    #1
    Okay, so I really need some help/advice. I bought an iPhone 3gs and it was on 3.1.3 firmware. I'm on T-Mobile, so I got straight to jailbreaking it. I jailbroke it with Spirit and it was really fast and insanely easy. Then I got on Cydia and installed blackra1n to unlock it. It completed and said that the download was done but there was a popup saying that it was updating the data that didnt let me do anything. So I left it for a while, but then turned off the phone. When I turned it back on, it went to the apple logo then a white loading bar with the apple aurora background. It filled the loading bar completey, but still hadnt changed. So I left it for a while again. When I look back at it, it was on the same screenshot. So I turned it off and on again. But this time, it only went as far as the apple logo. I did this two more times with the same result. I tried to fix by putting in recovery mode. I plugged it into itunes but to restore it, i'd have to update it to 4.3.4. I know that i could jailbreak 4.3.4 with redsn0w or pwnagetool. But i'm afraid that it would change my baseband to 4.3.4 and I know that there is no unlock for that baseband. So now I dont know if i should let itunes update it and risk trying to unlock it or if i should downgrade it as soon as it updates. (but downgrading looks really complicated and im not sure if i can do that) Or maybe there's a way to fix it without updating it? HELP!
     
  2. mutchy126 macrumors regular

    Joined:
    May 8, 2011
    Location:
    UK
    #2
    Bad!

    Sounds like something went very wrong in the process and you need a DFU Mode! :(

    DFU Instructions for anyone that does not know how: http://adf.ly/2Bj85
     

Share This Page