Problem with Lion Server to host Time Machine disk

Discussion in 'Mac OS X Lion (10.7)' started by kingsapo, Aug 15, 2011.

  1. kingsapo macrumors member

    Joined:
    Jun 10, 2010
    #1
    Hi! So for a while I've been using Snow Leopard Server with my old Mini, splitting the internal 500GB HD into 2 partitions, 1 50GB for OS X and 1 450GB for backups, then sharing the second partition over my network for my other computers to backup to. Before Lion, this worked great!

    Recently I upgraded that computer to Lion Server, and all my other computers to Lion. Now, that same setup does not work. Time Machine is giving me that "required AFP features" error message. I know Lion requires NetaTalk 2.2 (I think) for all NAS stuff. So it would make sense if I was using a 3rd party NAS to backup to, which would be running an older version of NetaTalk. But I'm using Lion Server to host the disk! Does this mean that Apple hasn't patched Lion to support NetaTalk 2.2 even though their own OS requires it? None of this makes any sense, but then again, these problems usually don't.

    Is anyone else having issues like this? Does anyone know if Apple is working on a fix for this? Does anyone have any possible solutions? Any help is greatly appreciated!
     
  2. nzamps macrumors newbie

    Joined:
    Aug 15, 2011
    #2
    Probably not related but I had issues backing up from multiple machines to the Lion Server (Time Machine) - I had to login to the server as the 1st user who backed up to it (!) i.e. using their credentials from each machine. So some kind of permission problem I suspect...
     
  3. kingsapo thread starter macrumors member

    Joined:
    Jun 10, 2010
    #3
    Thanks for the response, that sounds like a pain in the arse! Anyway, I checked the permissions for my time machine disk, setting everything that was there to Read and Write permission. Then, I got all excited cause I saw it in the list of TM disks, but got that same error message when I backed up.

    I also found a new issue. I share three external hard drives over the network, using Lion Server, and set the permissions on everything to Read and Write for everyone. However, when I access them from my other machine, I can't write anything past the first folder, or the root of the drive.

    Combined with other reports I've seen across the net, it looks like Apple has quite a few bugs to squash. In the meantime, I'll be attaching those drives directly to my machine, and possibly downgrading to Snow Leopard until Apple releases 10.7.1 or 2 (I've heard they're skipping over .1 for some reason). I know it's a bit irrelevant to this post, but do you happen to know if you can restore from a time machine backup that's made by an OS newer than your machine? (i.e., if I backed up my machine using Lion, then tried to restore using Snow Leopard, would it work?)
     

Share This Page