problem with macbook connecting to wireless: help please

Discussion in 'Mac Basics and Help' started by ashjamben, Mar 1, 2009.

  1. ashjamben macrumors 6502a

    Joined:
    Oct 28, 2007
    Location:
    Shanghai, China
    #1
    thanks for reading this thread.

    i have a linksys WRT54G2 router connected straight from the ethernet port of a cable internet connection. it's been working fine for the past month or two for both me (using macbook 10.5.6), my flatmate (running vista pc) and my girlfriend also running a macbook.

    but, the last few days i've been having problems getting connected. which are:

    not connecting to wireless network automatically, and asking for password which is already remembered in keychain
    getting connection timeout when trying to connect
    getting invalid password, even though password is correct
    websites taking around 2 mins to load when connection is eventually made

    the internet is working fine on both my flatmates and girlfriends computers, but jut doesn't seem to like mine. heres what i've done already:

    restored router to factory settings and updated with latest firmware
    cleared all known wireless networks within network preferences
    tried both firefox and safari
    accessed router using IP address and loaded pages instantly
    works fine connected to router with an ethernet cable

    the only thing i havn't tried is a different wireless network, which i'm going to try tomorrow when i go into university.

    has anyone any idea what the problem may be? like i said, its been working fine for the past 2 months but has just decided it doesn't like my macbook.

    any help or suggestions would be great, thanks alot
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Yeah, that'd be the place to start. Let us know how that goes and we'll go from there.
     
  3. ashjamben thread starter macrumors 6502a

    Joined:
    Oct 28, 2007
    Location:
    Shanghai, China
    #3
    the funny thing is it's working now, but now it's not working with my girlfriends.

    i'm using a WEP key and my girlfriends macbook says incompatible security. hers is a 2.1Ghz macbook running 10.5.5 and mines a 2.2Ghz macbook running 10.5.6. any ideas to that?
     
  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #4
    Do WPA2 if possible or WPA.

    Set up using a different wireless network name.
     
  5. ashjamben thread starter macrumors 6502a

    Joined:
    Oct 28, 2007
    Location:
    Shanghai, China
    #5
    i used a different name when setting up a new network.

    does anyone know how to set up WPA2? when i go to the linksys setup page in the browser and go to wireless security then choose WPA2 it doesn't generate a passphrase for me. i'm not sure if it requires just hex, ascii or just anything.

    also, i tried a different wireless and it worked fine. it's now also working fine, but occasionally getting connection timeouts and slow pages, but probably something i can live with.
     

Share This Page