Problem with Macbook HD?

Discussion in 'Mac Pro' started by dextertangocci, Jul 13, 2006.

  1. dextertangocci macrumors 68000

    Apr 2, 2006
    Hi everyone,

    Yesterday I repaired disk permissions, and verified the disk on my MB's HD. When I verified my disk, it givs me a weird message, as seen in the pic below. It tells me that I need to repair the disk, but it doesn't give me the option of repairing the disk:confused: It is there, but you can't click on it:confused: I tried to verify the disk, because I was having a couple of minor problems, like if I dragged something to my Macbook's HD, Finder sometimes just restarted, for no reason:confused:

    I also ram the Apple hardware test, and it said nothing was wrong:confused:

    Here's the message it gave:

    My second problem. I purchased Apple's bluetooth mouse yesterday, and downloaded the Apple wireless mouse and wireless keyboard updater. It opened from the dmg file perfectly, and installed the updater. It then takes me to the utilities folder, and shows me two icons, one of a keyboard, one of a mouse. I click on the mouse, and the icon opens in the dock for a split second, and then disappears. Is this meant to happen? Is the update already installed, when I opened the package inside the dmg file? If so, why did it take me to the utilities folder and show me the icon of the mouse and keyboard? If it is not installed, could it be something to do with my HD?



    Attached Files:

  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    You have to boot from the OSX disc to repair the internal hard drive as you cannot repair the drive you've booted from. Hold down C as you start up, with the disc in the optical drive and then select Disk Utility from the Installer menu. If the disc isn't handy, then run fsck. :)

    Are the Bluetooth devices working?
  3. Mechcozmo macrumors 603


    Jul 17, 2004
    Restart the Mac while holding Command+S
    When you get to the prompt, type "fsck -yf" (without quotes)
    Hit enter
    When the prompt returns, type "shutdown -r now"
    Hit enter
  4. dextertangocci thread starter macrumors 68000

    Apr 2, 2006
    Thanks Mad Jew and Mechcozmo:)

    It worked, and my disk is now repaired:)

    My bluetooth mouse updater also installs now:) :) :)

    People on this forum are so helpful:)
  5. dollystereo macrumors 6502a


    Oct 6, 2004
    I have an external drive with this problem, can I run FSCK over it?
    Please help is a 8 month work!!!
  6. theblotted macrumors regular


    Nov 10, 2006
    Los Angeles
    external drives don't need to use single-user mode (Apple S, fsck).

    just run disk utility, choose the external HD, and click "repair drive".

    or use Disk Warrior.

Share This Page