Problem with MacBook Wireless: Weak Signal

Discussion in 'MacBook' started by CvZ, Sep 20, 2008.

  1. CvZ macrumors newbie

    Joined:
    Sep 20, 2008
    #1
    I have a very new 2.4 GHz MacBook. For about 45 minutes after start-up, I can receive only a very weak wireless signal--two bars at most--regardless of how close I am to my Airport Express. It's all but impossible to get online.... I also have a 4-year-old G4 iBook, which has no problems with the Airport Express. When both computers are side by side, the iBook gets a great signal, and the MacBook gets a lousy signal

    After about 45 minutes, however, the MacBook signal is fine. Any ideas?
     
  2. *Sandy* macrumors 6502

    Joined:
    May 15, 2008
    Location:
    Always in a path of a Hurricane!
    #2
    I hate to say this but i have had a few macbooks and one of mine did the same thing after sleeping it took awhile before i could get online, I ended up buying a 2.1 Macbook and it does not do it at all, I never found a cure??
     
  3. CvZ thread starter macrumors newbie

    Joined:
    Sep 20, 2008
    #3
    Thanks

    Thanks for the response. Yikes--If you're right, I just spent a lot of money on something that will lessen my productivity. I have an appointment with the genius bar, but that's always such a production. I generally love Apple products, but this has been pretty disappointing, as it has a huge impact on the machine's usefulness.
     
  4. mlemonds macrumors 6502a

    mlemonds

    Joined:
    Apr 9, 2008
    Location:
    Lexington, KY
    #4
    i had that problem for a while, but i chalked it up to being around many many other networks and having a 2.4 ghz cordless phone. I changed the frequency of my router and have not had any problems since.

    This may not have anything to do with your problem, but i would give it a shot.
     
  5. *Sandy* macrumors 6502

    Joined:
    May 15, 2008
    Location:
    Always in a path of a Hurricane!
    #5
    I tried everything from changing channels toa new router, nothing ever worked for it, i would want to wake it from sleep to check something and it seemed like forever to connect, i also would disconnect sometimes for no reason was very strange this one connects instantly
     
  6. vtecman macrumors newbie

    Joined:
    Jan 6, 2008
    #6
    Wow, I cant believe that I googled this problem and I ran into quite a few responses. I have the first macbook (core duo) and I have done everything to troubleshoot this problem. I have replaced my linksys router with an apple time capsule too! Formatted my OS and started from scratch twice. I have no clue what it could be. No other 2.4 interference either.
     

Share This Page