Problem with Modifier Keys (Word, CS5 and Google SketchUp)

Discussion in 'MacBook Pro' started by Jalinx, Jul 21, 2010.

  1. Jalinx macrumors newbie

    Joined:
    Jul 21, 2010
    #1
    Hello,
    I need your help. I have problems with my Modifiers Keys.
    I have a MacBook Pro 15’ with OSX 10.5.8 and for some reason the Modifier Keys work for some tasks and for others don’t.

    The programs in which I noticed something wrong were Microsoft Word, Photoshop and Google Sketch Up.

    In Word the Option+Arrow keys to skip words doesn’t work.
    In CS5 Photoshop, when I use the Option key to set the source point for the Clone Tool, the secondary menu appears. Also Using the keyboard shortcut for the Zoom tool (Comand+Space Bar) and trying to get the Zoom Out (Comand+Space Bar+ Option) the secondary menu cursor icon appears as well.

    In Google SketchUp Pro 7 when I try to duplicate some object using the Comand key (as shown in their tutorials) it doesn’t work.

    I went to System Preferences/Keyboard and Mouse/Modifiers Keys restored everything and I get the same results. :confused: I think it is some setting on the Mac system, but my Mac-knowledge just ran out.

    Please some help!!!!!!!

    Saludos to everyone
     
  2. Jalinx thread starter macrumors newbie

    Joined:
    Jul 21, 2010
    #2
    Problem solved

    I fixed my problem!
    I read some threads about the Modifier Keys not working due connecting keyboards to the laptops and the solutions were to reconect the same keyboard to reset to default the setting.
    I just connected the first keyboard to my computer, went to System Preferences and restore to default settings, unppluged the keyboard and all my problems were solved.
    Thanks anyway to the people who read my post.
    Bye
    :D
     

Share This Page