Problem with Mosaic Screensaver

Discussion in 'macOS' started by ribbonthecat, Nov 11, 2007.

  1. ribbonthecat macrumors regular

    Joined:
    May 23, 2006
    Location:
    Chicago, IL
    #1
    Every time my screensaver launches, it shows the same image from my photos folder, and a progress bar which is labelled "Creating Mosaic Database..."

    It never seems to finish, and the screensaver always quits. When I try to change the settings in System Preferences, specifically when I go to Screensavers, System Preferences "unexpectedly quits."

    Does anyone have any suggestions for how to fix the problem, or has anybody had similar problems? I'm running 10.5.0 on a 24' iMac 2.4Ghz.
     
  2. ribbonthecat thread starter macrumors regular

    Joined:
    May 23, 2006
    Location:
    Chicago, IL
    #2
    I seem to have gotten around it: I moved my photo folder, and then disabled mosaic, without system preferences quitting. But the problem seems to be Mosaic on my system: enabling it causes Systems Preferences to quit. Any ideas?
     
  3. cork macrumors newbie

    Joined:
    Nov 25, 2007
    #3
    Same problem!

    I've got the exact same problem. I reinstalled the system. I trashed the systemprefs and it's still doing it. Moving the photo folder helped a bit but I still can't can't get back to the normal slide show with KenBurns effects. Any ideas are welcome.
     
  4. ChronoYu macrumors member

    Joined:
    Dec 21, 2007
    #4
    Me too!

    Yeah, I too have the exact SAME problem! How long has this problem been going on? I've just got an imac yesterday (10.5 with leopard) *sorry, still new with this so can't explain too well about my mac*.

    Is there anyway to solve this? Does Apple know about this problem?
    I'm actually kind of disappointed with Apple now. I thought that Mac wouldn't have any problems. At least not as bad as Windows. Well, that's true, but it still has problems. When I was buying it, there was this other man who happened to be an Apple user for many years already. He said that he has been a Mac user for 5 years already and has had no complains since. Yet I've just got a new one and I've got lots of problems already. What's going on?:confused:
     
  5. cayce macrumors newbie

    Joined:
    Jan 24, 2008
    #5
    Problem with Mosaic Screensaver

    I have had my new iMac for a couple of weeks now and just discovered the Mosaic option on the screensaver preference. I wish that I had read this thread before trying it! I was trying the Forest screensaver and then the Cosmos one and both quit while trying to load the Mosaic mode. I was not able to go back into the straight picture mode. Now I cannot even go into the desktop in System Preferences without the whole thing unexpectedly quitting. The last time I tried it, my mouse froze. Rebooting the computer didn't help and I had to turn the computer off at the power strip and then back on to get it working again.

    Interestingly, I have another user set up on my computer and that account is not freezing, since the Mosaic Mode has never been used. If all else fails, I'll create a new user for myself and delete the current one. I'd hate to have to go through all of that setup again though.

    If anyone has found a less cumbersome solution, please let me know.
     
  6. ChronoYu macrumors member

    Joined:
    Dec 21, 2007
    #6
    The solution is like what ribbonthecat said before.
    Mosaic screensaver requires enough photos in your iPhotos library to run. So for the meantime, try removing all your photos in iPhotos or adding more in it (so that it will run properly). Doing either one of these SHOULD solve it. I had the same problem before (as you can see the post before yours) and this solved it. We got this solution from the sales person at the Mac centre where we bought our iMac. She's one of those very rare helpful people. Hope this works!
     
  7. snowleopardxman macrumors newbie

    snowleopardxman

    Joined:
    May 1, 2010
    #7
    I need help!

    I'm trying to use the Mosaic feature and I am tying to load these photos on my Mac and nothing happens. it says "you need at least 100 photos" I HAVE OVER 300 PHOTOS!?!?!?
     
  8. manskybook macrumors newbie

    Joined:
    Feb 9, 2010
    #8
    Mosaic screen saver: troubleshooting

    Because Mosaic is always running when selected, simply deleting the preferences won't work. They'll be immediately recreated, and the problem will persist. What you have to do is de-select the Mosaic icon (it may be helpful to change other parameter by a tiny amount; e.g. move the time slider up or down a few minutes). Also, make sure a folder of photos with a sufficient number is selected in the Folder dialogue. Then close System Preferences and delete the preference plist com.apple.iphotomosaic in your ~Library/Preferences/ folder. Empty your Trash (for additional assurance, you may wish to log out or restart - if so, please check to see if com.apple.iphotomosaic has been recreated).

    If the plist no longer exists, return to the screensaver preferences in System Preferences and, first, make sure a large pictures folder is selected, as in the previous step; the re-select the Mosaic icon. It will rebuild Mosaic database, but this time it will likely complete.

    This might be the solution to your problem.
     
  9. cristobalviel macrumors member

    Joined:
    Dec 6, 2010
    Location:
    Santiago
    #9
    happend the same thing to me.... have you solve the problem ?
     

Share This Page