Problem with my dvd encodes for apple tv.

Discussion in 'Apple TV and Home Theater' started by JBaughb, May 11, 2008.

  1. JBaughb macrumors newbie

    Joined:
    May 11, 2008
    #1
    So i've decided to rip my dvds to the appletv but I am having a problem with my encodes and I think it might just be that I am using the wrong settings.

    I use MTR to rip the main feature then encoding using handbrake with appletv settings (slightly tweaked)

    I keep framerate same as source (29.97), x264 with 2 pass encoding at 2500 bitrate.

    For audio I use DTS 5.1 and select 6 channel discrete.

    One of the problems I am having is the video has a lot of lines during fast action scenes. It looks like some sort of interlace problem. Do I need to deinterlace this video? Im not sure how to tell which of my dvds need to be deinteraced and which do not.

    The other issue is with the audio. I have a pioneer elite receiver thats connected to the appletv using optical digital connection but my receiver says it is only receiving a stereo signal. Movies I have rented are coming through fine with 5.1.

    Anyway, Im thinking I dont have some settings right for the encode and I did do a search but I couldnt find the answers I needed.

    Also, my Apple TV is modded but the only thing i've added was perian to play back divx and xvid.

    Any help would be appreciated. thanks to all!
     
  2. mallbritton macrumors 6502a

    Joined:
    Nov 26, 2006
    #2
    In general movies don't need to be deinterlaced. But TV shows might need to be. I generally always deinterlace TV shows just to be on the safe side. If you are seeing horizontal lines during fast transitions then, yes, your encode should be deinterlaced. Use the "slow" setting.

    As to Audio -- you should use the default :apple:TV setting in Handbrake (AC3+AAC). Your encoded videos will then play fine and your receiver will get a DD 5.1 signal.

    Regards,
    Michael
     
  3. Mernak macrumors 6502

    Joined:
    Apr 9, 2006
    Location:
    Kirkland, WA
    #3
    If you want to tell whether or not a show/movie needs to be deinterlaced, you can always flip through the different previews that handbrake gives you, if any one of them is interlaced, try the deinterlace and it should apply the setting to the preview picture and see if it is better, it's not foolproof, but it helps. I do this just because deinterlacing on slow takes a while, so I try to avoid it when possible.
     
  4. JBaughb thread starter macrumors newbie

    Joined:
    May 11, 2008
    #4
    Thanks both of you for your advice on the deinterlacing. Its very helpful.

    A little clarification on the audio though. Does this mean the apple tv cant handle DTS 5.1? Id prefer DTS over DD ac3. Or is it just that the apple tv is trying to pass the AAC audio to my receiver to decode and its not able to do that. Ugh, so confusing.

    Also what is the difference between the Track 1 and Track 1 Mix audio options in handbrake?

    Thanks again.
     
  5. NightStorm macrumors 68000

    Joined:
    Jan 26, 2006
    Location:
    Whitehouse, OH
    #5
    Why are you changing the framerate to 29.97?

    Also, Handbrake cannot create a MP4 file with DTS passthru (I know of no program that can), and the majority of consumer receivers cannot decode AAC 5.1. Just use AAC + AC3 as mentioned earlier, and select the AC3 5.1 soundtrack on the DVD.
     
  6. JBaughb thread starter macrumors newbie

    Joined:
    May 11, 2008
    #6
    handbrake is showing the framerate of the source dvd as 29.97. I havent changed anything.

    Thanks for the info on the audio. That clarifies why my receiver is just thinking its stereo.
     
  7. NightStorm macrumors 68000

    Joined:
    Jan 26, 2006
    Location:
    Whitehouse, OH
    #7
    If that's the case, deinterlacing and/or VFR may help you out. I'd recommend skipping 'Fast' deinterlacing and using 'Slow'.
     

Share This Page