Problem With My Iphone Pls Help

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ksabek, Aug 27, 2009.

  1. ksabek macrumors member

    Sep 15, 2008
    ok i know this might sound stupid but im enrolled in the iphone developers program n i downloaded os 3.1 beta but im having problems with the phone i cant call properly!! i want to return to 3.0 but i cant...i need the file itself bcuz itunes recognizes 3.1 as the latest OS n cant go back...does any1 have an idea how to help me?
  2. Tallest Skil macrumors P6

    Tallest Skil

    Aug 13, 2006
    1 Geostationary Tower Plaza
  3. orionpower macrumors member

    Oct 1, 2007
    you can find them on the Iclarified web page.

    let me know if you need more help
  4. dejo Moderator


    Staff Member

    Sep 2, 2004
    The Centennial State
    Connect your device and then select it in the Organizer window of Xcode. In the Summary tab, select 3.0 for the Software Version and then click Restore iPod.
  5. ksabek thread starter macrumors member

    Sep 15, 2008
    i tried this and i see the 3.0 but i cannot select to restore my iphone!
    xcode tells ms:
    The version of iPhone OS on “Karim Al-Sabek’s iPhone” does not match any of the versions of iPhone OS supported for development with this copy of Xcode. Please restore the device to a version of the OS listed below. If necessary, the latest version of Xcode is available here.
    and says that 3.0 is supported but i cannot choose it!
  6. ksabek thread starter macrumors member

    Sep 15, 2008
    i went to iclarified and found a file for os 3.0 n downloaded n when trying to restore the iphone error code 1015 pops up, what should i do?! i searched google and found out that i need to jailbreak my iphone, is there any other way?!
  7. kate-willbury macrumors 6502a

    Feb 14, 2009

Share This Page