Problem with new LG Drive in G5 2.0Ghz

Discussion in 'PowerPC Macs' started by soundbase, Jul 1, 2009.

  1. soundbase macrumors member

    May 17, 2009
    I am having a problem with a new LG Drive I have installed in my G5 2.0Ghz

    When I insert a DVD, it comes up as an untitled CD, even though it is a DVD. And when it burns, it fails after 700MB.

    Here are the details on the drive:


    Firmware Revision: 1.02
    Interconnect: ATAPI
    Burn Support: Yes (Unsupported)
    Profile Path: None
    Cache: 2048 KB
    Reads DVD: Yes
    CD-Write: -R, -RW
    DVD-Write: -R, -RAM, -RW, +R, +RW, +R DL
    Burn Underrun Protection CD: Yes
    Burn Underrun Protection DVD: Yes
    Write Strategies: CD-TAO, CD-SAO, CD-Raw, DVD-DAO
    Media: No

    I have tried Liquid CD, but when it asks me to insert a black disc, I insert a blank DVD, and then it just says waiting for drive, and never gets anywhere.

    I have also tried another disk, but no luck.

    Can anyone help. Is there something I am missing. Is it a problem with the OS or the drive?

    It is happening on another G5 of mine with the same new LG drive. So it is not just that LG drive
  2. Timmahman macrumors newbie

    Jun 19, 2009
    Virginia, USA
    Maybe the drive isent compatible with OSX?
    Id try using them on a PC and see if they work under windows, then you can narrow it down to a compatibility issue and not a hardware issue.
  3. soundbase thread starter macrumors member

    May 17, 2009
    Problem with LG Drive and OS X

    I have tried different discs. Still no Luck. I have an HD with Tiger installed and an HD with Leopard installed. With leopard the Blank DVD comes up as an Untitled DVD. But when I try burn a disc it says it need e.g 2444MB to burn, and then you cannot burn the DVD. IF I use Liquid CD on leopard it picks up the blank disc, but when I try burn is also says it need a certain amount of space even though the data I have chosen to burn is less than 4GB.

    With the Tiger install it comes up as Untitled CD when I insert a DVD, I tried Patchburn for Tiger, but that does still not resolve it.

    Eventually I installed Toast, and that seemed to solve the problem. But is there any way to get it to burn natively on Tiger and Leopard?

Share This Page