Problem with nvidia 330m

Discussion in 'MacBook Pro' started by Pedromperez, Sep 27, 2010.

  1. Pedromperez macrumors newbie

    Joined:
    Feb 13, 2010
    #1
    Hello,

    I recently purchased my Macbook Pro and Starcraft II. When I put in the game defaults I get 10fps. Is this happening to someone else?, is my graphics card damaged?, how can I tell?. Or maybe is a problem with Starcraft II on the mac?.

    How can I check my Macbook Pro 2.4 330m graphics card?, maybe is a problem with the automatic graphics switching? even thou I´d tried with the option enabled and disabled.

    Thank you for your help
     
  2. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
    #2
    use gfxcardstatus to tell what GFX is in use, and change it if you want.
    http://codykrieger.com/gfxCardStatus/

    SCII is really badly coded for the mac. it just about kills everything else going on. try to search the forums and see what people have been writing about it. I just have everything that requires the GPU on low until it gets fixed.
     
  3. DJ-R macrumors regular

    DJ-R

    Joined:
    Feb 17, 2010
    Location:
    Toronto, Canada
    #3
    Seriously? I did not know that I've been playing on Windows before I got this MBP. Thanks for the head up.
     
  4. newbiemacguy128 macrumors regular

    Joined:
    Jul 8, 2009
    #4
    I've been playing SC2 on my MBP constantly since it came out on my i7.

    In windows, i can do mostly high settings with native resolution with no problem.

    On OSX, i can do mostly medium settings with native resolution with no problem.

    Also, i don't know if this is still a problem, but i heard restricting the fps to 30 helps keep the heat down and improved gameplay. At least it did for me.

    Anyways, i don't really notice a difference in graphics going from medium > high. I love SC2 for the gameplay, not the graphics. Would be a nice bonus though =P.
     

Share This Page