Problem with old iMac

Discussion in 'iMac' started by ashman70, Aug 2, 2011.

  1. ashman70 macrumors 6502a

    Joined:
    Dec 20, 2010
    #1
    I have a clients old iMac its a 4,1 model. They were having issues with the beach ball spinning all the time, the airport stopped working, this is what I did.

    Tried resetting PRAM, made no difference.
    Started fixing permissions and it found a lot of errors.
    Stopped that, booted off a SL install disc, tried to repair the drive, it failed, said to backup your files, reformat and reinstall.

    Now when I try to boot it, the white screen with the Apple logo comes up and at the bottom of the screen there is what a looks like a long progress indicator, it starts to show progress and then the whole machine powers off. The SL disc is still in the machine. I am not pressing any keys during boot.

    What should I do?

    I have half a mind to open it up, pull the drive, put a new drive in, reinstall SL and then plug the original drive in as an external to copy their files back.

    AM
     
  2. SawceBaws macrumors member

    Joined:
    Aug 1, 2011
    #2
    Take it to Apple. Don't try and DIY, it could damage it even more.
     
  3. ashman70 thread starter macrumors 6502a

    Joined:
    Dec 20, 2010
    #3
    Well I am quite conversant with Apple hardware, I have no qualms about taking it apart and replacing the drive, or that I may damage it.

    I am just wondering if there is anything else I can try to get it to boot off the drive. I have removed the SL disc now.

    AM
     
  4. ashman70 thread starter macrumors 6502a

    Joined:
    Dec 20, 2010

Share This Page