Problem with Pages '08 - Cannot see text!

Discussion in 'Mac Apps and Mac App Store' started by stop.the.clocks, Mar 14, 2012.

  1. stop.the.clocks macrumors newbie

    Joined:
    Nov 10, 2011
    #1
    I have had this problem before and had to re-install the damn thing. I am typing, the text is set to 'black' but I cannot see anything on the page, only when I highlight what has been written. Surely I'm overlooking a simple solution, but I cannot find any option.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Have you tried restarting your computer?
    Does it happen with all Pages documents?
    Have you tried creating a new user account, to see if it happens there, as well?
    What version of Mac OS X and what version of Pages are you running?

    How to maximise your MacRumors troubleshooting experience
     
  3. PeggyD macrumors 6502a

    Joined:
    Jan 9, 2007
    Location:
    Covington, WA, USA
    #3
    There are two things that fix this problem in both iWork '08 & '09.

    If you're not running the latest versions & Software Update says your software is up to date, make sure the applications are where the installer initially put them. The updaters are very picky. If the location is not where the updater is programmed to look or if the folder doesn't have the name the updater looks for, it will not work. The applications cannot be renamed or moved. If you installed from the downloaded trial or the retail box, they must be in the iWork '08 folder in Applications. That iWork folder must be named iWork '08. If it doesn't have the '09 Software Update won't find them & the updaters won't work.

    The problem is not whether or not your system is the current version but how it got there. You must use the combo updater, not the one from Software Update unless it specifically states it is the combo. Software Update will only offer the combo if your system is two or more versions behind.
     
  4. stop.the.clocks thread starter macrumors newbie

    Joined:
    Nov 10, 2011
    #4
    GGJstudios - I have tried it all, no other users on this machine.

    PeggyD - I did have it in an renamed folder, tried moving it back but to no avail. I miss the days when Macs just worked. :(
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    Re-read my post. I wasn't asking if there were other users. I suggested creating a new user account to test.
     
  6. CylonGlitch macrumors 68030

    CylonGlitch

    Joined:
    Jul 7, 2009
    Location:
    SoCal
    #6
    It is possible that the font used is not available or got corrupted.

    CMD-A, Select a font from the pulldown and then select a color. See if that changes anything. Also when typing CMD-A, does it look like it is selecting things or does it appear to be a blank document?

    Is this happening for EVERY document or just one?
     
  7. PeggyD macrumors 6502a

    Joined:
    Jan 9, 2007
    Location:
    Covington, WA, USA
    #7
    You can't just move the folder back or rename it, you then need to run Software Update to make sure the apps are x.0.3, especially that Pages is 3.0.3. You also must run the combo 10.6.8 updater.
     
  8. stop.the.clocks thread starter macrumors newbie

    Joined:
    Nov 10, 2011
    #8
    Thanks for the input guys.

    I solved this after re-sintalling iWork and by keeping the default 'save location' settings. Everything is fine again (for now).
     

Share This Page