Problem with Pages

Discussion in 'Mac Apps and Mac App Store' started by Janettelufer, Aug 26, 2014.

  1. Janettelufer macrumors newbie

    Joined:
    Aug 26, 2014
    #1
    When I click on a Pages document in the 'Documents' section of my dock, it doesn't open in Pages. Instead, the document's package contents appear. The same problem occurs with Numbers and Keynote. Is there a way to resolve this?
     

    Attached Files:

  2. neutrino23 macrumors 68000

    Joined:
    Feb 14, 2003
    Location:
    SF Bay area
    #2
    I just tried this. Make an alias to the document and place the alias in the dock. I clicked on the alias in the doc and it opened the document in Pages. There might be other ways but this worked.
     
  3. Brian33 macrumors 6502a

    Joined:
    Apr 30, 2008
    Location:
    USA (Virginia)
    #3
    Odd. I tried it too, and the document opens with Pages as I'd expect. Maybe it depends upon what version of OS X is running -- I'm using 10.8.5 Mountain Lion.

    Are you sure you have set those file types to be opened with the Pages app? Go to Finder and pick "Get Info" for the .pages file and look at the "Open with" setting...
     
  4. Janettelufer thread starter macrumors newbie

    Joined:
    Aug 26, 2014
    #4
    I'm using Mavericks, but my iMac is running Mavericks as well and it isn't experiencing this problem. I just checked and I have set for the files to be open with Pages.

    ----------

    Thanks for the temporary solution. I'm wondering why it's doing this as my MacBook is new. Maybe there's something wrong with the computer?
     
  5. ApfelKuchen macrumors 68030

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #5
    This suggests that the option to Show Package Contents is somehow set as a default.

    Does this also happen when you open Documents in a Finder window? What happens when you click on other package types (dmg, zip, iTunes and iPhoto libraries), both in Documents and in other folders?
     
  6. Janettelufer thread starter macrumors newbie

    Joined:
    Aug 26, 2014
    #6
    No, this only happens when I try to open it from my Documents stack. Other package types seem fine, this only occurs with Pages, Numbers, and Keynote.
     
  7. George Wilson macrumors newbie

    Joined:
    Aug 7, 2012
    Location:
    Swansea
    #7
    Problems with Pages

    I have a similar problem, in that attempting to open any Pages doc in the Cloud elicits the response that the doc can't be opened. If I drag it to the desktop it then opens fine in Pages, but that's now on my desktop where I don't want it to be.
     

Share This Page